You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@jmeter.apache.org by bu...@apache.org on 2018/11/05 14:00:31 UTC
[Bug 62885] New: AccessLogSampler Parser for AWS load balancer
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
Bug ID: 62885
Summary: AccessLogSampler Parser for AWS load balancer
Product: JMeter
Version: 5.0
Hardware: PC
OS: Mac OS X 10.1
Status: NEW
Severity: enhancement
Priority: P2
Component: Main
Assignee: issues@jmeter.apache.org
Reporter: paul.carr@ii.co.uk
Target Milestone: JMETER_5.1
Hi , I've just found your access log sampler, and think it's fantastic. I can
now run a load test from prod in QA , which is great.
I then thought I'd do the same with our AWS site , and discovered the standard
parsers do not handle the AWS ALB log format very well. I've attached a small
snippet of an AWS ALB access log .... any chance you could knock up a parser
for it ?
--
You are receiving this mail because:
You are the assignee for the bug.
[Bug 62885] AccessLogSampler Parser for AWS load balancer
Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
--- Comment #3 from Felix Schumacher <fe...@internetallee.de> ---
Created attachment 36252
--> https://bz.apache.org/bugzilla/attachment.cgi?id=36252&action=edit
Add more http methods for parsing log files
The attached patch adds all the http methods, that are available in the
HTTPSamplerBase. OPTIONS is one of them, so the AWS log files should be
parseable with this patch.
--
You are receiving this mail because:
You are the assignee for the bug.
[Bug 62885] AccessLogSampler Parser for AWS load balancer
Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
Felix Schumacher <fe...@internetallee.de> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |NEEDINFO
--- Comment #2 from Felix Schumacher <fe...@internetallee.de> ---
Can you elaborate a bit more on what is not working for you? Is it the OPTIONS
http verb or something entirely different?
--
You are receiving this mail because:
You are the assignee for the bug.
[Bug 62885] AccessLogSampler Parser for AWS load balancer
Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
Philippe Mouawad <p....@ubik-ingenierie.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Hardware|PC |All
OS|Mac OS X 10.1 |All
Target Milestone|JMETER_5.1 |---
CC| |p.mouawad@ubik-ingenierie.c
| |om
--
You are receiving this mail because:
You are the assignee for the bug.
[Bug 62885] AccessLogSampler Parser for AWS load balancer
Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
--- Comment #4 from Philippe Mouawad <p....@ubik-ingenierie.com> ---
Hi Felix,
Thanks for the patch.
Wouldn't it be an occasion to rename the TCLogParser so that they respect
naming conventions ?
Maybe before applying the patch so that it's clear ?
Thanks
--
You are receiving this mail because:
You are the assignee for the bug.
[Bug 62885] AccessLogSampler Parser for AWS load balancer
Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
Too Tall <to...@gmail.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|NEEDINFO |NEW
--
You are receiving this mail because:
You are the assignee for the bug.
[Bug 62885] AccessLogSampler Parser for AWS load balancer
Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
--- Comment #1 from paulca <pa...@ii.co.uk> ---
Created attachment 36244
--> https://bz.apache.org/bugzilla/attachment.cgi?id=36244&action=edit
AWS ALB LOG SNIPPET
--
You are receiving this mail because:
You are the assignee for the bug.
[Bug 62885] AccessLogSampler Parser for AWS load balancer
Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
--- Comment #5 from Felix Schumacher <fe...@internetallee.de> ---
Renaming is probably not a good idea, since the class seems to be intended to
be used for subclassing.
Having slept a night about the changes, I am not so sure anymore, that is OK to
add more methods by default, as those could change existing tests. So I think
it would be better to introduce a new property that allows more methods, or add
a variable to the bean, that would be used for configuration.
--
You are receiving this mail because:
You are the assignee for the bug.
[Bug 62885] AccessLogSampler Parser for AWS load balancer
Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=62885
Too Tall <to...@gmail.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #36252|0 |1
is obsolete| |
CC| |tootallmiers13@gmail.com
--- Comment #6 from Too Tall <to...@gmail.com> ---
Created attachment 38209
--> https://bz.apache.org/bugzilla/attachment.cgi?id=38209&action=edit
Rooty
--
You are receiving this mail because:
You are the assignee for the bug.