You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@drill.apache.org by Daniel Barclay <db...@maprtech.com> on 2015/01/20 01:45:01 UTC

Review Request 30059: Synchronized, cleaned up, and documented SendingAccountor.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/30059/
-----------------------------------------------------------

Review request for drill, Jacques Nadeau and Jason Altekruse.


Repository: drill-git


Description
-------

Technical change:  Added "synchronized" to  increment().

Other changes:  Documentation and renaming for clarity.


Diffs
-----

  exec/java-exec/src/main/java/org/apache/drill/exec/physical/impl/SendingAccountor.java 7af7b65 

Diff: https://reviews.apache.org/r/30059/diff/


Testing
-------

Ran developer and QA tests; got no errors other than errors that appear for master branch.


Thanks,

Daniel Barclay


Re: Review Request 30059: Synchronized, cleaned up, and documented SendingAccountor.

Posted by Daniel Barclay <db...@maprtech.com>.

> On Jan. 20, 2015, 2:52 a.m., Jacques Nadeau wrote:
> > exec/java-exec/src/main/java/org/apache/drill/exec/physical/impl/SendingAccountor.java, line 54
> > <https://reviews.apache.org/r/30059/diff/1/?file=825995#file825995line54>
> >
> >     Synchronized is fine.  You can remove comments.

Roger.


> On Jan. 20, 2015, 2:52 a.m., Jacques Nadeau wrote:
> > exec/java-exec/src/main/java/org/apache/drill/exec/physical/impl/SendingAccountor.java, line 94
> > <https://reviews.apache.org/r/30059/diff/1/?file=825995#file825995line94>
> >
> >     Yes, it should.

Roger.


- Daniel


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/30059/#review68685
-----------------------------------------------------------


On Jan. 20, 2015, 12:45 a.m., Daniel Barclay wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/30059/
> -----------------------------------------------------------
> 
> (Updated Jan. 20, 2015, 12:45 a.m.)
> 
> 
> Review request for drill, Jacques Nadeau and Jason Altekruse.
> 
> 
> Repository: drill-git
> 
> 
> Description
> -------
> 
> Technical change:  Added "synchronized" to  increment().
> 
> Other changes:  Documentation and renaming for clarity.
> 
> 
> Diffs
> -----
> 
>   exec/java-exec/src/main/java/org/apache/drill/exec/physical/impl/SendingAccountor.java 7af7b65 
> 
> Diff: https://reviews.apache.org/r/30059/diff/
> 
> 
> Testing
> -------
> 
> Ran developer and QA tests; got no errors other than errors that appear for master branch.
> 
> 
> Thanks,
> 
> Daniel Barclay
> 
>


Re: Review Request 30059: Synchronized, cleaned up, and documented SendingAccountor.

Posted by Jacques Nadeau <ja...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/30059/#review68685
-----------------------------------------------------------



exec/java-exec/src/main/java/org/apache/drill/exec/physical/impl/SendingAccountor.java
<https://reviews.apache.org/r/30059/#comment113035>

    Let's not change this everywhere.



exec/java-exec/src/main/java/org/apache/drill/exec/physical/impl/SendingAccountor.java
<https://reviews.apache.org/r/30059/#comment113036>

    Synchronized is fine.  You can remove comments.



exec/java-exec/src/main/java/org/apache/drill/exec/physical/impl/SendingAccountor.java
<https://reviews.apache.org/r/30059/#comment113037>

    Yes, it should.


- Jacques Nadeau


On Jan. 20, 2015, 12:45 a.m., Daniel Barclay wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/30059/
> -----------------------------------------------------------
> 
> (Updated Jan. 20, 2015, 12:45 a.m.)
> 
> 
> Review request for drill, Jacques Nadeau and Jason Altekruse.
> 
> 
> Repository: drill-git
> 
> 
> Description
> -------
> 
> Technical change:  Added "synchronized" to  increment().
> 
> Other changes:  Documentation and renaming for clarity.
> 
> 
> Diffs
> -----
> 
>   exec/java-exec/src/main/java/org/apache/drill/exec/physical/impl/SendingAccountor.java 7af7b65 
> 
> Diff: https://reviews.apache.org/r/30059/diff/
> 
> 
> Testing
> -------
> 
> Ran developer and QA tests; got no errors other than errors that appear for master branch.
> 
> 
> Thanks,
> 
> Daniel Barclay
> 
>