You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mahout.apache.org by "Grant Ingersoll (Created) (JIRA)" <ji...@apache.org> on 2011/11/03 21:55:32 UTC

[jira] [Created] (MAHOUT-868) Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh

Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
-------------------------------------------------------------------------------------------------------

                 Key: MAHOUT-868
                 URL: https://issues.apache.org/jira/browse/MAHOUT-868
             Project: Mahout
          Issue Type: Improvement
            Reporter: Grant Ingersoll
            Assignee: Grant Ingersoll
            Priority: Minor
             Fix For: 0.6


The build*.sh scripts in examples/bin are a bit weird naming wise.  We should deprecate them and rename them to something more explanatory.

Since we have a fair amount of stuff pointing to the old ones, however, I would suggest we keep them around for a release or two and have them simply call the new one, along with printing out a short message saying they should use the other one next time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (MAHOUT-868) Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh

Posted by "Joe Prasanna Kumar (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAHOUT-868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13144550#comment-13144550 ] 

Joe Prasanna Kumar commented on MAHOUT-868:
-------------------------------------------

How about this
current -> build-cluster-syntheticcontrol.sh : proposed -> cluster-syntheticcontrol.sh
current -> build-asf-email.sh : proposed -> recommend-classify-cluster-asf-email.sh
current -> build-reuters.sh : proposed -> cluster-reuters.sh
current -> factorize-movielens-1M.sh : proposed -> recommend-movielens-1M.sh

the format being <recommend or cluster or classify>-<dataset>.sh

The build-asf-email.sh and factorize-movielens-1M.sh doesnt have code to download the dataset. I think itz better if we can modify the script to download the dataset. Shud I proceed modifying the scripts and upload a patch ?

reg
Joe

                
> Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
> -------------------------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-868
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-868
>             Project: Mahout
>          Issue Type: Improvement
>            Reporter: Grant Ingersoll
>            Assignee: Grant Ingersoll
>            Priority: Minor
>              Labels: MAHOUT_INTRO_CONTRIBUTE
>             Fix For: 0.6
>
>
> The build*.sh scripts in examples/bin are a bit weird naming wise.  We should deprecate them and rename them to something more explanatory.
> Since we have a fair amount of stuff pointing to the old ones, however, I would suggest we keep them around for a release or two and have them simply call the new one, along with printing out a short message saying they should use the other one next time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (MAHOUT-868) Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh

Posted by "Grant Ingersoll (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAHOUT-868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13144554#comment-13144554 ] 

Grant Ingersoll commented on MAHOUT-868:
----------------------------------------

bq.  Shud I proceed modifying the scripts and upload a patch ?

I don't think we can download the ASF email, since it is a public dataset on AWS.  Plus, it is fairly large and would take a long time.

I like the naming conventions for the most part, although build-asf-email gets a bit long name-wise, but is livable.  Perhaps that one should just be process-asf-email?

Otherwise, yep, go for it.

Let's make sure we update the wiki, too.
                
> Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
> -------------------------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-868
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-868
>             Project: Mahout
>          Issue Type: Improvement
>            Reporter: Grant Ingersoll
>            Assignee: Grant Ingersoll
>            Priority: Minor
>              Labels: MAHOUT_INTRO_CONTRIBUTE
>             Fix For: 0.6
>
>
> The build*.sh scripts in examples/bin are a bit weird naming wise.  We should deprecate them and rename them to something more explanatory.
> Since we have a fair amount of stuff pointing to the old ones, however, I would suggest we keep them around for a release or two and have them simply call the new one, along with printing out a short message saying they should use the other one next time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (MAHOUT-868) Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh

Posted by "Joe Prasanna Kumar (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/MAHOUT-868?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Joe Prasanna Kumar updated MAHOUT-868:
--------------------------------------

    Attachment: MAHOUT-868-examples-rename.sh

This is a script that does "svn mv" to rename the scripts in examples/bin.
Once this is executed, then i'll modify the wiki pages to reflect the new names
                
> Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
> -------------------------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-868
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-868
>             Project: Mahout
>          Issue Type: Improvement
>            Reporter: Grant Ingersoll
>            Assignee: Grant Ingersoll
>            Priority: Minor
>              Labels: MAHOUT_INTRO_CONTRIBUTE
>             Fix For: 0.6
>
>         Attachments: MAHOUT-868-examples-rename.sh
>
>
> The build*.sh scripts in examples/bin are a bit weird naming wise.  We should deprecate them and rename them to something more explanatory.
> Since we have a fair amount of stuff pointing to the old ones, however, I would suggest we keep them around for a release or two and have them simply call the new one, along with printing out a short message saying they should use the other one next time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (MAHOUT-868) Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh

Posted by "Grant Ingersoll (Resolved) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/MAHOUT-868?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Grant Ingersoll resolved MAHOUT-868.
------------------------------------

    Resolution: Fixed
    
> Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
> -------------------------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-868
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-868
>             Project: Mahout
>          Issue Type: Improvement
>            Reporter: Grant Ingersoll
>            Assignee: Grant Ingersoll
>            Priority: Minor
>              Labels: MAHOUT_INTRO_CONTRIBUTE
>             Fix For: 0.6
>
>         Attachments: MAHOUT-868-examples-rename.sh
>
>
> The build*.sh scripts in examples/bin are a bit weird naming wise.  We should deprecate them and rename them to something more explanatory.
> Since we have a fair amount of stuff pointing to the old ones, however, I would suggest we keep them around for a release or two and have them simply call the new one, along with printing out a short message saying they should use the other one next time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (MAHOUT-868) Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh

Posted by "Hudson (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAHOUT-868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13155146#comment-13155146 ] 

Hudson commented on MAHOUT-868:
-------------------------------

Integrated in Mahout-Quality #1191 (See [https://builds.apache.org/job/Mahout-Quality/1191/])
    MAHOUT-868: rename scripts to drop the build stuff.  also added a README

gsingers : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1204734
Files : 
* /mahout/trunk/examples/bin/README.txt
* /mahout/trunk/examples/bin/asf-email-examples.sh
* /mahout/trunk/examples/bin/build-asf-email.sh
* /mahout/trunk/examples/bin/build-cluster-syntheticcontrol.sh
* /mahout/trunk/examples/bin/build-reuters.sh
* /mahout/trunk/examples/bin/cluster-reuters.sh
* /mahout/trunk/examples/bin/cluster-syntheticcontrol.sh

                
> Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
> -------------------------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-868
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-868
>             Project: Mahout
>          Issue Type: Improvement
>            Reporter: Grant Ingersoll
>            Assignee: Grant Ingersoll
>            Priority: Minor
>              Labels: MAHOUT_INTRO_CONTRIBUTE
>             Fix For: 0.6
>
>         Attachments: MAHOUT-868-examples-rename.sh
>
>
> The build*.sh scripts in examples/bin are a bit weird naming wise.  We should deprecate them and rename them to something more explanatory.
> Since we have a fair amount of stuff pointing to the old ones, however, I would suggest we keep them around for a release or two and have them simply call the new one, along with printing out a short message saying they should use the other one next time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (MAHOUT-868) Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh

Posted by "Grant Ingersoll (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/MAHOUT-868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13154688#comment-13154688 ] 

Grant Ingersoll commented on MAHOUT-868:
----------------------------------------

Thanks, Joe.  I committed most of your patch, but made the old scripts be pass throughs to the new ones (with a deprecation warning), as I figured we have a fair amount of documentation out on them already.  Also added a README.  I left factorize off b/c I wasn't sure how Sebastian wanted to handle those.
                
> Rename build*.sh examples to be more indicative of what they actually do, i.e. classify-20newsgroups.sh
> -------------------------------------------------------------------------------------------------------
>
>                 Key: MAHOUT-868
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-868
>             Project: Mahout
>          Issue Type: Improvement
>            Reporter: Grant Ingersoll
>            Assignee: Grant Ingersoll
>            Priority: Minor
>              Labels: MAHOUT_INTRO_CONTRIBUTE
>             Fix For: 0.6
>
>         Attachments: MAHOUT-868-examples-rename.sh
>
>
> The build*.sh scripts in examples/bin are a bit weird naming wise.  We should deprecate them and rename them to something more explanatory.
> Since we have a fair amount of stuff pointing to the old ones, however, I would suggest we keep them around for a release or two and have them simply call the new one, along with printing out a short message saying they should use the other one next time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira