You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@fineract.apache.org by "Adam Saghy (Jira)" <ji...@apache.org> on 2026/06/09 12:48:00 UTC

[jira] [Updated] (FINERACT-2630) Use Collection.isEmpty() instead of size() comparison in fineract-savings

     [ https://issues.apache.org/jira/browse/FINERACT-2630?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Adam Saghy updated FINERACT-2630:
---------------------------------
    Fix Version/s: 1.15.0

> Use Collection.isEmpty() instead of size() comparison in fineract-savings
> -------------------------------------------------------------------------
>
>                 Key: FINERACT-2630
>                 URL: https://issues.apache.org/jira/browse/FINERACT-2630
>             Project: Apache Fineract
>          Issue Type: Improvement
>            Reporter: Berk Emir
>            Priority: Major
>             Fix For: 1.15.0
>
>
> Following the cleanup done in FINERACT-2627 for the fineract-loan module, several Collection.size() > 0 emptiness checks remain in the fineract-savings module. These should use Collection.isEmpty(), which is more readable and clearly expresses intent (SonarQube rule java:S1155). This applies the same refactor to SavingsAccount, SavingsAccountRepositoryWrapper and SavingsSchedularInterestPoster. No behavioural change.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)