You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@atlas.apache.org by "David Radley (JIRA)" <ji...@apache.org> on 2018/01/04 16:30:01 UTC

[jira] [Commented] (ATLAS-2298) OCF JDBC Connector for GaianDB

    [ https://issues.apache.org/jira/browse/ATLAS-2298?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16311590#comment-16311590 ] 

David Radley commented on ATLAS-2298:
-------------------------------------

[~Yao 22] I suggest adding the code that generates the jdbc javadoc into the review board tool - as this makes it easier to track issues.

Some initial comments on the javadoc :
1) I notice in the javadoc that JDBCConnectorErrorCode contains an extra /**
2) I notice public class ConnectionCheckedException extends JDBCConnectorCheckedExceptionBase. From the naming,  it is not obvious that ConnectionCheckedException has anything to do with JDBC from the name. 
3) The same for ExecutionCheckedException. 
4) to ease readability in 2 and 3 I suggest removing the checked from the names - as the runtime already indicated those exceptions are unchecked. 
     - renaming JDBCConnectorCheckedExceptionBase to JDBCConnectorException
     - renaming ConnectionCheckedException to ConnectionJDBCConnectorException
     - renaming ExecutionCheckedException to ExecutionJDBCConnectorException
5) In JDBCConnectorRuntimeException 	getReportedCaughtException() returns a Throwable - should this method be getReportedThrowable
6)  In JDBCConnectorRuntimeException getReportedSystemAction() - is this system action reported? I suggest removing the "reported" from the name. Same for "getReportedUserAction()" and "getReportedHTTPCode()"
7) Maybe rename GaianDBJDBCConnector to GaianJDBCConnector for readability
8) 	For setDBUrlCreateFalse(java.lang.String realUserId) set up the proper database url, create is false. 
     - I suggest we pass a second boolean flag parameter rather than have 2 methods.
     - what does create true and false mean?
     - what is the proper database?
     - what is the realUserId?
     - what does this mean "realUserId - used by the tempory GaianDB db url for authentication". What is temporary about this and what is real about it?
9) for ConnectionCheckedException - it says "there may be the odd bug that surfaces here." I suggest removing this. When should we use  "JDBCConnectorErrorCode" and when should be use " messages defined uniquely for a ConnectorProvider/Connector implementation"




  


> OCF JDBC Connector for GaianDB
> ------------------------------
>
>                 Key: ATLAS-2298
>                 URL: https://issues.apache.org/jira/browse/ATLAS-2298
>             Project: Atlas
>          Issue Type: Improvement
>          Components:  atlas-core
>            Reporter: Maryna Strelchuk
>            Assignee: Yao Li
>         Attachments: JDBC Connector Java Doc.zip, OCF JDBC Connector.pdf
>
>
> This Jira is focused on development of the OCF JDBC Connector for the GaianDB which will be used to access data from GaianDB.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)