You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jetspeed-dev@portals.apache.org by ji...@apache.org on 2004/05/25 22:02:00 UTC

[jira] Created: (JS2-54) Clean up jetspeed.groovy assembly script

Message:

  A new issue has been created in JIRA.

---------------------------------------------------------------------
View the issue:
  http://issues.apache.org/jira/browse/JS2-54

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: JS2-54
    Summary: Clean up jetspeed.groovy assembly script
       Type: Task

     Status: Open
   Priority: Major

    Project: Jetspeed 2
 Components: 
             Container
   Versions:
             2.0-a1

   Assignee: Scott T Weaver
   Reporter: Scott T Weaver

    Created: Tue, 25 May 2004 1:01 PM
    Updated: Tue, 25 May 2004 1:01 PM

Description:
1. Remove all references to NanoContainer
2. Write a simple unit test that verifies that the assembly script is syntactically correct and that the Engine initiallizes.
3. Make the assembly script generally more readable/easier to work with.


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


[jira] Closed: (JS2-54) Clean up jetspeed.groovy assembly script

Posted by ji...@apache.org.
Message:

   The following issue has been closed.

---------------------------------------------------------------------
View the issue:
  http://issues.apache.org/jira/browse/JS2-54

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: JS2-54
    Summary: Clean up jetspeed.groovy assembly script
       Type: Task

     Status: Closed
   Priority: Major
 Resolution: FIXED

    Project: Jetspeed 2
 Components: 
             Container
   Versions:
             2.0-a1

   Assignee: Scott T Weaver
   Reporter: Scott T Weaver

    Created: Tue, 25 May 2004 1:01 PM
    Updated: Fri, 28 May 2004 7:32 AM

Description:
1. Remove all references to NanoContainer
2. Write a simple unit test that verifies that the assembly script is syntactically correct and that the Engine initiallizes.
3. Make the assembly script generally more readable/easier to work with.


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


[jira] Commented: (JS2-54) Clean up jetspeed.groovy assembly script

Posted by ji...@apache.org.
The following comment has been added to this issue:

     Author: David Sean Taylor
    Created: Tue, 25 May 2004 3:07 PM
       Body:
IMO Jetspeed's current state of Nano assembly is unstable.
The errors are cryptic, no line numbers in Groovy script.
Error messages misleading, gotchas everywhere
Is this the environment we want for assemblers?

Example:
I found out why I couldn't build from the CVS for the last few weeks.
I still don't know why the constructor was satisfied by Pico for others.

DLS checked in the jetspeed.groovy script adding UserInfo support, he forgot to add his import statements.
Once I added those, the build started working.
Groovy/Nano never complained about the imports, but then the constructor on the request context was sometimes satisfied (for the lucky individuals), and for me it failed.

To summarize... yes the freaking syntax looks better :-)
But please, as you stated, lets test the hell out of this assembly and try to get it to provide decent error messages on failure. I spent a lot of time chasing down the example above, and there have been other cases as you well know. 

---------------------------------------------------------------------
View this comment:
  http://issues.apache.org/jira/browse/JS2-54?page=comments#action_35721

---------------------------------------------------------------------
View the issue:
  http://issues.apache.org/jira/browse/JS2-54

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: JS2-54
    Summary: Clean up jetspeed.groovy assembly script
       Type: Task

     Status: Open
   Priority: Major

    Project: Jetspeed 2
 Components: 
             Container
   Versions:
             2.0-a1

   Assignee: Scott T Weaver
   Reporter: Scott T Weaver

    Created: Tue, 25 May 2004 1:01 PM
    Updated: Tue, 25 May 2004 3:07 PM

Description:
1. Remove all references to NanoContainer
2. Write a simple unit test that verifies that the assembly script is syntactically correct and that the Engine initiallizes.
3. Make the assembly script generally more readable/easier to work with.


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


[jira] Commented: (JS2-54) Clean up jetspeed.groovy assembly script

Posted by ji...@apache.org.
The following comment has been added to this issue:

     Author: Scott T Weaver
    Created: Tue, 25 May 2004 1:08 PM
       Body:
For increasing the usability of the jetspeed.groovy assembly script, I capitalized on Groovy's closure support.

// Shorthand for creating a ConstantParameter
cstParam = { key | return  new ConstantParameter(key) }

// Shorthand for creating a ComponentParameter
cmpParam = { key | return  new ComponentParameter(key) }

// Closure to perform easy building of Parameter[]
doParams = 
{
    paramList |  paramArray = new Parameter[paramList.size()]
                       i = 0
                       for(param in paramList)
                      {
                         paramArray[i]   =  param                    
                         i++
                      }
                      return paramArray
}

which allows us to go from this:
    container.registerComponentImplementation(PortletEntityAccessComponent, PortletEntityAccessComponentImpl, new Parameter[] {new ComponentParameter(PersistenceStoreContainer), new ConstantParameter("jetspeed")} )

to this much more readable and concise statement:

container.registerComponentImplementation(
                            PortletRegistryComponent, 
                            PortletRegistryComponentImpl,                             doParams([cmpParam(PersistenceStoreContainer), cstParam("jetspeed")])
)




---------------------------------------------------------------------
View this comment:
  http://issues.apache.org/jira/browse/JS2-54?page=comments#action_35719

---------------------------------------------------------------------
View the issue:
  http://issues.apache.org/jira/browse/JS2-54

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: JS2-54
    Summary: Clean up jetspeed.groovy assembly script
       Type: Task

     Status: Open
   Priority: Major

    Project: Jetspeed 2
 Components: 
             Container
   Versions:
             2.0-a1

   Assignee: Scott T Weaver
   Reporter: Scott T Weaver

    Created: Tue, 25 May 2004 1:01 PM
    Updated: Tue, 25 May 2004 1:08 PM

Description:
1. Remove all references to NanoContainer
2. Write a simple unit test that verifies that the assembly script is syntactically correct and that the Engine initiallizes.
3. Make the assembly script generally more readable/easier to work with.


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org