You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@camel.apache.org by "Andrea Cosentino (Jira)" <ji...@apache.org> on 2025/06/19 20:36:00 UTC

[jira] [Commented] (CAMEL-22183) camel-fury - Rename Fury to Fory

    [ https://issues.apache.org/jira/browse/CAMEL-22183?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17983751#comment-17983751 ] 

Andrea Cosentino commented on CAMEL-22183:
------------------------------------------

We'll do this before the next LTS, 4.13.0

> camel-fury - Rename Fury to Fory
> --------------------------------
>
>                 Key: CAMEL-22183
>                 URL: https://issues.apache.org/jira/browse/CAMEL-22183
>             Project: Camel
>          Issue Type: Task
>            Reporter: Matti Tuomikoski
>            Assignee: Andrea Cosentino
>            Priority: Trivial
>             Fix For: 4.13.0
>
>
> Apache Fury serialization framework was renamed to Apache Fory ([https://fory.apache.org/blog/fury_renamed_to_fory)|https://fory.apache.org/blog/fury_renamed_to_fory).]
> This should be taken into account on some level at Camel side as well. Looks like the latest 0.11.0 version was already released only on org.apache.fory groupId and also using Fory instead of Fury in class names etc. So that change will be inevitable.
> One option could be to rename everything in one go on a 4.x minor release?



--
This message was sent by Atlassian Jira
(v8.20.10#820010)