You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@mesos.apache.org by "Adam B (JIRA)" <ji...@apache.org> on 2017/08/16 21:50:01 UTC
[jira] [Updated] (MESOS-7560) Add 'type' and 'name' to
ResourceProviderInfo.
[ https://issues.apache.org/jira/browse/MESOS-7560?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Adam B updated MESOS-7560:
--------------------------
Labels: storage (was: )
> Add 'type' and 'name' to ResourceProviderInfo.
> ----------------------------------------------
>
> Key: MESOS-7560
> URL: https://issues.apache.org/jira/browse/MESOS-7560
> Project: Mesos
> Issue Type: Task
> Reporter: Jie Yu
> Assignee: Jie Yu
> Labels: storage
> Fix For: 1.4.0
>
>
> The 'type' field will be used to load the corresponding implementation (either internal or via module). To avoid conflict, the naming should follow java packing naming scheme (e.g., org.apache.mesos.resource_provider.local.storage).
> Since there could be multiple instances of the same resource provider type, it's important to also add a 'name' field to distinguish between instances of the same type.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)