You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Till Rohrmann (JIRA)" <ji...@apache.org> on 2014/07/01 02:03:26 UTC
[jira] [Created] (FLINK-994) Replace DataInput and DataOutput of
IOReadableWritable with DataInputView and DataOutputView
Till Rohrmann created FLINK-994:
-----------------------------------
Summary: Replace DataInput and DataOutput of IOReadableWritable with DataInputView and DataOutputView
Key: FLINK-994
URL: https://issues.apache.org/jira/browse/FLINK-994
Project: Flink
Issue Type: Improvement
Reporter: Till Rohrmann
Assignee: Till Rohrmann
The DataInput and DataOutput view are not well designed interfaces with a limited function set. Therefore, we should replace the DataInput and DataOutput by the Flink defined DataInputView and DataOutputView in the IOReadableWritable interface. This is a preparative step for the serializer and input/output abstraction rework.
--
This message was sent by Atlassian JIRA
(v6.2#6252)