You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Henri Yandell <ba...@generationjava.com> on 2002/06/19 18:50:48 UTC

Re: [Lang] Increasing its role


On Wed, 19 Jun 2002 scolebourne@btopenworld.com wrote:

> OK. Like collections will have, there should be a note somewhere in
> the project (developers guide?) to say that is the naming convention.

Sounds good.

> No, what I meant was an instantiable StringBuffer, not a StringBufferUtils. Thus you write
> UStringBuffer buf = new UStringBuffer();
> thus the buffer can be manipulated accordingly. (UStringBuffer would implement all the methods of StringBuffer for compatability). BTW, there is probably a better name!
>
> Also, there was a discussion on JavaLobby recently where direct manipulation of char arrays was requested. So maybe there should be a Chars utility class with all the functionality, which Strings and UStringBuffer delegate to.

Both sound good. I'm just chomping at maintaining the same functionality
three times.

> > Once Lang is released, then I can release a 1.0 of String taglib depending
> > on it. So time for me to focus hard on Lang I think.
>
> All makes sense. Hopefully when my CVS is confirmed I can contribute?

Would be great. Do you want to start by pushing your serialisation cloner
in? I haven't checked it yet, but it sounds far more mature than the one
I have.


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


[Lang] Serialization [was: Increasing its role]

Posted by Stephen Colebourne <sc...@btopenworld.com>.
I've committed the serialization changes I suggested as new classes. I
haven't removed the methods from Objects at the moment, because the
functionality is slightly different.

The code in Objects allowed you to serialize to and from a byte[]. If an
error occurred it was silently absorbed. In the code I have committed,
errors are thrown as SerializationException (runtime exception, as this
error should be picked up during testing). Full test cases added as well.

If I hear nothing back, I will remove the old methods from Objects.

Stephen

----- Original Message -----
From: "Stephen Colebourne" <sc...@btopenworld.com>
To: "Jakarta Commons Developers List" <co...@jakarta.apache.org>
Sent: Wednesday, June 19, 2002 6:45 PM
Subject: Re: [Lang] Increasing its role


> From: "Henri Yandell" <ba...@generationjava.com>
> > On Wed, 19 Jun 2002 scolebourne@btopenworld.com wrote:
> > Do you want to start by pushing your serialisation cloner
> > in? I haven't checked it yet, but it sounds far more mature than the one
> > I have.
>
> To confirm, I should create a new Serialization class and move the methods
> about serialization from Objects.
>
>  Are we worried about deprecation, or is this truly sandbox? (I'm hoping
its
> truly sandbox ;-)
>
> Stephen
>
>
>
>
> --
> To unsubscribe, e-mail:
<ma...@jakarta.apache.org>
> For additional commands, e-mail:
<ma...@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: [Lang] Increasing its role

Posted by Stephen Colebourne <sc...@btopenworld.com>.
From: "Henri Yandell" <ba...@generationjava.com>
> On Wed, 19 Jun 2002 scolebourne@btopenworld.com wrote:
> Do you want to start by pushing your serialisation cloner
> in? I haven't checked it yet, but it sounds far more mature than the one
> I have.

To confirm, I should create a new Serialization class and move the methods
about serialization from Objects.

 Are we worried about deprecation, or is this truly sandbox? (I'm hoping its
truly sandbox ;-)

Stephen




--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>