You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@flink.apache.org by "Fabian Hueske (JIRA)" <ji...@apache.org> on 2016/01/02 10:18:39 UTC

[jira] [Created] (FLINK-3198) Rename Grouping.getDataSet() method and add JavaDocs

Fabian Hueske created FLINK-3198:
------------------------------------

             Summary: Rename Grouping.getDataSet() method and add JavaDocs
                 Key: FLINK-3198
                 URL: https://issues.apache.org/jira/browse/FLINK-3198
             Project: Flink
          Issue Type: Improvement
          Components: DataSet API
    Affects Versions: 0.10.1, 1.0.0
            Reporter: Fabian Hueske
             Fix For: 1.0.0, 0.10.2


The {{getDataSet()}} method of {{Grouping}} is public and visible to users. It returns the input of the grouping operation which can cause confusion. If this function is used in a regular DataSet program like this

{code}
DataSet<X> notGrouped = input.groupBy().getDataSet();
DataSet<Y> allReduced = notGrouped.reduce()
{code}

the previous {{groupBy()}} call is basically discarded and an AllReduce is applied instead of a grouped Reduce.

Since this method is not meant to be part of the public API we should help users to avoid this method. In the current API, we cannot easily change the visibility of the method without package restructuring or adding additional classes (and hence breaking binary compatibility).

Instead I proprose to rename the method to something like {{getInputDataSet()}} or {{getGroupingInput()}} and add descriptive JavaDocs.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)