You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-dev@hadoop.apache.org by "Yi Liu (JIRA)" <ji...@apache.org> on 2014/07/30 14:32:38 UTC

[jira] [Created] (HDFS-6787) Remove duplicate code in FSDirectory#unprotectedConcat

Yi Liu created HDFS-6787:
----------------------------

             Summary: Remove duplicate code in FSDirectory#unprotectedConcat
                 Key: HDFS-6787
                 URL: https://issues.apache.org/jira/browse/HDFS-6787
             Project: Hadoop HDFS
          Issue Type: Bug
          Components: namenode
    Affects Versions: 3.0.0
            Reporter: Yi Liu
            Assignee: Yi Liu
         Attachments: HDFS-6787.001.patch

{code}
// update inodeMap
removeFromInodeMap(Arrays.asList(allSrcInodes));
{code}
this snippet of code is duplicate, since we already have the logic above it:
{code}
    for(INodeFile nodeToRemove: allSrcInodes) {
      if(nodeToRemove == null) continue;
      
      nodeToRemove.setBlocks(null);
      trgParent.removeChild(nodeToRemove, trgLatestSnapshot);
      inodeMap.remove(nodeToRemove);
      count++;
    }
{code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)