You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Greg Hudson <gh...@MIT.EDU> on 2002/11/17 19:15:33 UTC

Path interface cleanup

I'm not sure if this is controversial, but I'll check.  I'd like to
clean up the path functions to avoid having stringbuf/char* ways of
doing everything.

For most of the functions (svn_path_add_component, svn_path_split,
svn_path_is_empty, svn_path_canonicalize, and svn_path_compare_paths),
this means ditching the stringbuf form and renaming the _nts form to
ditch the _nts suffix.

For svn_path_remove_component, this means ditching the _nts version.
Functions which use svn_path_remove_component_nts can use
svn_path_split instead.

The end result is that svn_path_add_component and
svn_path_remove_component will operate on an svn_stringbuf_t (but use
a const char * for the path component being added), and all the other
functions will operate on const char * arguments.

I will go ahead and start working on this, but will wait a couple of
days for -1s before committing the result if I'm successful.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: Path interface cleanup

Posted by Karl Fogel <kf...@newton.ch.collab.net>.
Greg Hudson <gh...@MIT.EDU> writes:
> The end result is that svn_path_add_component and
> svn_path_remove_component will operate on an svn_stringbuf_t (but use
> a const char * for the path component being added), and all the other
> functions will operate on const char * arguments.
> 
> I will go ahead and start working on this, but will wait a couple of
> days for -1s before committing the result if I'm successful.

Sounds great!  If it looks easy to remove the stringbuf forms
entirely, and change those calls to use svn_path_split() or whatever,
+1 on that too.

-K



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: Path interface cleanup

Posted by Greg Hudson <gh...@MIT.EDU>.
On Sun, 2002-11-17 at 14:15, Greg Hudson wrote:
> For svn_path_remove_component, this means ditching the _nts version.
> Functions which use svn_path_remove_component_nts can use
> svn_path_split instead.

I noticed we have svn_path_basename already.  Instead of doing away with
svn_path_remove_component_nts entirely, we could rename it to
svn_path_dirname.  So, take my proposal as amended thus.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org