You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@olingo.apache.org by "Michael Burwig (JIRA)" <ji...@apache.org> on 2015/04/07 14:47:12 UTC

[jira] [Updated] (OLINGO-622) Concurrency Issue in AbstractEdmStructuredType

     [ https://issues.apache.org/jira/browse/OLINGO-622?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Michael Burwig updated OLINGO-622:
----------------------------------
    Description: 
Package:
org.apache.olingo.commons.core.edm

Class:
AbstractEdmStructuredType

Method:
List<String> getPropertyNames()

Description:
This method does not appear to be thread-safe. While a first call might still work on filling the ArrayList, a second call would immediately return said list and potentially lead to a ConcurrentModificationException. This is especially problematic since the method name implies a read-only access to the API user.

  was:
Package:
org.apache.olingo.commons.core.edm

Class:
AbstractEdmStructuredType

Method:
List<String> getPropertyNames()

Description:
This method does not appear to be thread-safe. While a first call might still work on filling the ArrayList, a second call would immediately return said list and potentially lead to a ConcurrentModificationException.


> Concurrency Issue in AbstractEdmStructuredType
> ----------------------------------------------
>
>                 Key: OLINGO-622
>                 URL: https://issues.apache.org/jira/browse/OLINGO-622
>             Project: Olingo
>          Issue Type: Bug
>          Components: odata4-commons
>    Affects Versions: (Java) V4 4.0.0-beta-02, (Java) V4 4.0.0-beta-03
>            Reporter: Michael Burwig
>
> Package:
> org.apache.olingo.commons.core.edm
> Class:
> AbstractEdmStructuredType
> Method:
> List<String> getPropertyNames()
> Description:
> This method does not appear to be thread-safe. While a first call might still work on filling the ArrayList, a second call would immediately return said list and potentially lead to a ConcurrentModificationException. This is especially problematic since the method name implies a read-only access to the API user.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)