You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hive.apache.org by "Laszlo Bodor (Jira)" <ji...@apache.org> on 2019/09/18 09:43:00 UTC

[jira] [Comment Edited] (HIVE-22202) Remove unnecessary code from ObjectStore.java

    [ https://issues.apache.org/jira/browse/HIVE-22202?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16932244#comment-16932244 ] 

Laszlo Bodor edited comment on HIVE-22202 at 9/18/19 9:42 AM:
--------------------------------------------------------------

[~ghanko]: thanks for this refactor
I can't see why this line is removed: https://github.com/abstractdog/hive/commit/3c92843f042ecdff89aa473f0f3b6bf2f7dd61a8#diff-33821c5e69c8a323e566c485d0b3db7bL948
other than that, it looks good to me


was (Author: abstractdog):
[~ghanko]: thanks for this refactor
I can't why this line is removed: https://github.com/abstractdog/hive/commit/3c92843f042ecdff89aa473f0f3b6bf2f7dd61a8#diff-33821c5e69c8a323e566c485d0b3db7bL948
other than that, it looks good to me

> Remove unnecessary code from ObjectStore.java
> ---------------------------------------------
>
>                 Key: HIVE-22202
>                 URL: https://issues.apache.org/jira/browse/HIVE-22202
>             Project: Hive
>          Issue Type: Task
>          Components: Hive
>            Reporter: Hankó Gergely
>            Assignee: Hankó Gergely
>            Priority: Minor
>         Attachments: HIVE-22202.1.patch, HIVE-22202.2.patch, HIVE-22202.3.patch
>
>
> Remove unnecessary code
>  * remove unnecessary/unused variables
>  * remove unused private methods
>  * remove unnecessary throws declarations
>  * remove unnecessary conditionals that are guaranteed to always give the same result
>  * simplify collection handling
>  ** use member sort() instead of Collections.sort()
>  ** use addAll() instead of adding one-by-one in a loop
>  * remove Javadoc that doesn't give additional information
>  * use try with resource where possible
>  * remove unnecessary explicit type arguments
>  * remove redundant warning suppression



--
This message was sent by Atlassian Jira
(v8.3.4#803005)