You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@syncope.apache.org by Francesco Chicchiriccò <il...@apache.org> on 2026/07/20 09:20:25 UTC

CVE-2026-53421: Apache Syncope: Remote Code Execution via Scripted Connector

Severity: moderate 

Affected versions:

- Apache Syncope 3.0.0-M0 through 3.0.16
- Apache Syncope 4.0.0-M0 through 4.0.6
- Apache Syncope 4.1.0-M0 through 4.1.1

Description:

Improper Isolation or Compartmentalization vulnerability in Apache Syncope.



An administrator with adequate entitlements can achieve remote code execution through the connector subsystem by relying on scripted connectors' (REST and SQL) capability to run Groovy scripts.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1.




Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by hardening the Groovy security sandbox.

Credit:

follycat, Y0n3er (finder)

References:

https://syncope.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-53421