You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Kai Zheng (JIRA)" <ji...@apache.org> on 2017/03/21 03:12:41 UTC
[jira] [Commented] (HDFS-11541) Call RawErasureEncoder and
RawErasureDecoder release() methods
[ https://issues.apache.org/jira/browse/HDFS-11541?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15934024#comment-15934024 ]
Kai Zheng commented on HDFS-11541:
----------------------------------
Yes, this would be better to have, as exactly as the issue documented. Thanks for the reporting.
[~Sammi], ping you if you're interested in this. Thanks!
> Call RawErasureEncoder and RawErasureDecoder release() methods
> --------------------------------------------------------------
>
> Key: HDFS-11541
> URL: https://issues.apache.org/jira/browse/HDFS-11541
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Components: erasure-coding
> Affects Versions: 3.0.0-alpha2
> Reporter: László Bence Nagy
> Labels: hdfs-ec-3.0-nice-to-have
>
> The *RawErasureEncoder* and *RawErasureDecoder* classes have _release()_ methods which are not called from the source code. These methods should be called when an encoding or decoding operation is finished so that the dynamically allocated resources can be freed. Underlying native plugins can also rely on these functions to release their resources.
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org