You are viewing a plain text version of this content. The canonical link for it is here.
Posted to java-dev@axis.apache.org by "Patrick Cosmo (JIRA)" <ji...@apache.org> on 2009/07/09 19:45:15 UTC

[jira] Created: (AXIS2-4425) axutil_date_time_get_date is misnamed, it should be axutil_date_time_get_day

axutil_date_time_get_date is misnamed, it should be axutil_date_time_get_day
----------------------------------------------------------------------------

                 Key: AXIS2-4425
                 URL: https://issues.apache.org/jira/browse/AXIS2-4425
             Project: Axis 2.0 (Axis2)
          Issue Type: Bug
          Components: Tools
    Affects Versions: 1.6
         Environment: all
            Reporter: Patrick Cosmo
            Priority: Minor


when decoding a date, in axutil_date_time.h there is a method for extracting year, month, etc, but not for "day".
 
However, there is a method named: axutil_date_time_get_date( ... )
 
If you look at the implementation of this in date_time.c, it's actually extracting the day:
 
AXIS2_EXTERN int AXIS2_CALL
axutil_date_time_get_date(
    axutil_date_time_t *date_time,
    const axutil_env_t *env)
{
    return (date_time->day);
}
 
 
I think this function should be named axutil_date_time_get_day

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (AXIS2-4425) axutil_date_time_get_date is misnamed, it should be axutil_date_time_get_day

Posted by "Patrick Cosmo (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AXIS2-4425?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Patrick Cosmo updated AXIS2-4425:
---------------------------------

    Attachment: axutil_date_time.h
                rand.c
                date_time.c

This fixes the problem in axutil_date_time.h, date_time.c and rand.c.

The method is also referenced in date_time_test.c, I'll upload that one fixed in a minute.

> axutil_date_time_get_date is misnamed, it should be axutil_date_time_get_day
> ----------------------------------------------------------------------------
>
>                 Key: AXIS2-4425
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4425
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: Tools
>    Affects Versions: 1.6
>         Environment: all
>            Reporter: Patrick Cosmo
>            Priority: Minor
>         Attachments: axutil_date_time.h, date_time.c, rand.c
>
>
> when decoding a date, in axutil_date_time.h there is a method for extracting year, month, etc, but not for "day".
>  
> However, there is a method named: axutil_date_time_get_date( ... )
>  
> If you look at the implementation of this in date_time.c, it's actually extracting the day:
>  
> AXIS2_EXTERN int AXIS2_CALL
> axutil_date_time_get_date(
>     axutil_date_time_t *date_time,
>     const axutil_env_t *env)
> {
>     return (date_time->day);
> }
>  
>  
> I think this function should be named axutil_date_time_get_day

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (AXIS2-4425) axutil_date_time_get_date is misnamed, it should be axutil_date_time_get_day

Posted by "Patrick Cosmo (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AXIS2-4425?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Patrick Cosmo updated AXIS2-4425:
---------------------------------

    Attachment: date_time_test.c

This is the last file I found this issue in.

> axutil_date_time_get_date is misnamed, it should be axutil_date_time_get_day
> ----------------------------------------------------------------------------
>
>                 Key: AXIS2-4425
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4425
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: Tools
>    Affects Versions: 1.6
>         Environment: all
>            Reporter: Patrick Cosmo
>            Priority: Minor
>         Attachments: axutil_date_time.h, date_time.c, date_time_test.c, rand.c
>
>
> when decoding a date, in axutil_date_time.h there is a method for extracting year, month, etc, but not for "day".
>  
> However, there is a method named: axutil_date_time_get_date( ... )
>  
> If you look at the implementation of this in date_time.c, it's actually extracting the day:
>  
> AXIS2_EXTERN int AXIS2_CALL
> axutil_date_time_get_date(
>     axutil_date_time_t *date_time,
>     const axutil_env_t *env)
> {
>     return (date_time->day);
> }
>  
>  
> I think this function should be named axutil_date_time_get_day

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.