You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@groovy.apache.org by "Paul King (Jira)" <ji...@apache.org> on 2023/02/22 02:53:00 UTC

[jira] [Created] (GROOVY-10943) Consider additional use of _ as a placeholder

Paul King created GROOVY-10943:
----------------------------------

             Summary: Consider additional use of _ as a placeholder
                 Key: GROOVY-10943
                 URL: https://issues.apache.org/jira/browse/GROOVY-10943
             Project: Groovy
          Issue Type: Dependency upgrade
            Reporter: Paul King


Recent Java versions make underscore, "_", an illegal variable name. This is to allow it to be used as a placeholder as per JEP 302: Lambda Leftovers[1]. This issue is to explore how better to have such a placeholder in Groovy.

This strengthens an informal convention already in use. Instead of writing this:

{code}
def (coordX, coordY, unusedZ) = coord3D()
{code}

Sometimes it is written as:

{code}
def (coordX, coordY, _) = coord3D()
{code}


 [1] [https://openjdk.org/jeps/302]

 



--
This message was sent by Atlassian Jira
(v8.20.10#820010)