You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Yun Ni (JIRA)" <ji...@apache.org> on 2016/11/10 23:02:58 UTC

[jira] [Updated] (SPARK-18408) API Improvements for LSH

     [ https://issues.apache.org/jira/browse/SPARK-18408?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Yun Ni updated SPARK-18408:
---------------------------
    Description: 
As the first improvements to current LSH Implementations, we are planning to do the followings:
 - Change output schema to {{Array of Vector}} instead of {{Vectors}}
 - Use `numHashTables` as the dimension of {{Array}} and {{numHashFunctions}} as the dimension of {{Vector}}
 - Rename {{RandomProjection}} to {{BucketedRandomProjectionLSH}}, {{MinHash}} to {{MinHashLSH}}
 - Make randUnitVectors/randCoefficients private

  was:
As the first improvements to current LSH Implementations, we are planning to do the followings:
 - Change output schema to `Array of Vector` instead of `Vectors`
 - Use `numHashTables` as the dimension of `Array` and `numHashFunctions` as the dimension of `Vector`
 - Rename `RandomProjection` to `BucketedRandomProjectionLSH`, `MinHash` to `MinHashLSH`
 - Make randUnitVectors/randCoefficients private


> API Improvements for LSH
> ------------------------
>
>                 Key: SPARK-18408
>                 URL: https://issues.apache.org/jira/browse/SPARK-18408
>             Project: Spark
>          Issue Type: Improvement
>            Reporter: Yun Ni
>
> As the first improvements to current LSH Implementations, we are planning to do the followings:
>  - Change output schema to {{Array of Vector}} instead of {{Vectors}}
>  - Use `numHashTables` as the dimension of {{Array}} and {{numHashFunctions}} as the dimension of {{Vector}}
>  - Rename {{RandomProjection}} to {{BucketedRandomProjectionLSH}}, {{MinHash}} to {{MinHashLSH}}
>  - Make randUnitVectors/randCoefficients private



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org