You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Stephan Ewen (JIRA)" <ji...@apache.org> on 2014/07/11 14:01:09 UTC

[jira] [Commented] (FLINK-848) Move combine() from GroupReduceFunction to Interface

    [ https://issues.apache.org/jira/browse/FLINK-848?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14058695#comment-14058695 ] 

Stephan Ewen commented on FLINK-848:
------------------------------------

I think this is a subissue of [FLINK-701]

> Move combine() from GroupReduceFunction to Interface
> ----------------------------------------------------
>
>                 Key: FLINK-848
>                 URL: https://issues.apache.org/jira/browse/FLINK-848
>             Project: Flink
>          Issue Type: Improvement
>          Components: Java API
>            Reporter: GitHub Import
>              Labels: breaking-api, github-import
>             Fix For: pre-apache
>
>
> Currently, the combine method of the GroupReduceFunction allows to return multiple values using a collector. However, most combiners do not need this because they return only a single value. Furthermore, a single value returning combiner can be executed using more efficient hash-based strategies.
> Hence, we propose to introduce a combine method for GroupReduce which returns only a single value. In order to keep support for the rare cases where more than one value needs to be returned, we want to keep the collector-combiner as well.
> To do so, we could remove the combine method from the abstract GroupReduceFunction class and add two Combinable interfaces, one for a single-value and one for a multi-value combiner.
> This would also make the Combinable annotation obsolete as the optimizer can check whether a GroupReduceFunction implements one of the Combinable interfaces or not.
> ---------------- Imported from GitHub ----------------
> Url: https://github.com/stratosphere/stratosphere/issues/848
> Created by: [fhueske|https://github.com/fhueske]
> Labels: core, enhancement, 
> Milestone: Release 0.6 (unplanned)
> Created at: Thu May 22 10:23:04 CEST 2014
> State: open



--
This message was sent by Atlassian JIRA
(v6.2#6252)