You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Erik Erlandson (JIRA)" <ji...@apache.org> on 2014/08/07 23:13:12 UTC

[jira] [Created] (SPARK-2911) provide rdd.parent[T](j) to obtain jth parent of rdd

Erik Erlandson created SPARK-2911:
-------------------------------------

             Summary: provide rdd.parent[T](j) to obtain jth parent of rdd
                 Key: SPARK-2911
                 URL: https://issues.apache.org/jira/browse/SPARK-2911
             Project: Spark
          Issue Type: Improvement
          Components: Spark Core
            Reporter: Erik Erlandson
            Priority: Minor


For writing RDD subclasses that involve more than a single parent dependency, it would be convenient (and more readable) to say:

rdd.parent[T](j)

instead of:

rdd.dependencies(j).rdd.asInstanceOf[RDD[T]]





--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org