You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Hyukjin Kwon (JIRA)" <ji...@apache.org> on 2019/05/21 04:25:29 UTC
[jira] [Updated] (SPARK-14325) some strange name conflicts in
`group_by`
[ https://issues.apache.org/jira/browse/SPARK-14325?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Hyukjin Kwon updated SPARK-14325:
---------------------------------
Labels: bulk-closed (was: )
> some strange name conflicts in `group_by`
> -----------------------------------------
>
> Key: SPARK-14325
> URL: https://issues.apache.org/jira/browse/SPARK-14325
> Project: Spark
> Issue Type: Bug
> Components: SparkR
> Affects Versions: 1.6.0, 1.6.1
> Environment: sparkR 1.6.0
> Reporter: Dmitriy Selivanov
> Priority: Major
> Labels: bulk-closed
>
> group_by strange behaviour when try to aggregate by column with name "x".
> consider following example
> {code}
> df
> # DataFrame[userId:bigint, type:string, j:int, x:int]
> df %>%group_by(df$userId, df$type, df$j) %>% agg(x = "sum")
> #Error in (function (classes, fdef, mtable) :
> # unable to find an inherited method for function ‘agg’ for signature ‘"character"’
> {code}
> after renaming x -> x2 works just file.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org