You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@libcloud.apache.org by "John Carr (JIRA)" <ji...@apache.org> on 2013/09/06 20:19:55 UTC
[jira] [Commented] (LIBCLOUD-392) Add support for keypairs
management in the OpenStack driver
[ https://issues.apache.org/jira/browse/LIBCLOUD-392?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13760465#comment-13760465 ]
John Carr commented on LIBCLOUD-392:
------------------------------------
[~sebgoa] recently worked on these methods to CloudStack, and I have been tweaking the equivalent methods for EC2. It we be good if we good try and align and OpenStack tweaks so that all 3 drivers work similarly - so I write a script using them and they work for all 3 drivers.
Currently the EC2 driver has the following:
* ex_create_keypair
* ex_import_keypair_from_string
* ex_import_keypair
* ex_find_or_import_keypair_by_key_material (I'd like to shorten the name to just ex_find_or_import_keypair)
* ex_list_keypairs
* ex_describe_keypair (Should be renamed ex_get_keypair to be more consistent with other API's?)
These should be deprecated and removed IMO:
* ex_describe_all_keypairs (Should really be marked as deprecated)
* ex_describe_keypairs (Should really be marked as deprecated)
It doesn't currently have an ex_delete_keypair, but it should.
Right now the EC2 methods operate on and return dictionary objects that look a bit like this dict(keyName='key_name', keyFingerprint='00:...'). I would quite like to add a shared NodeAuthKeypair object that could be used for this API for all 3 drivers. This could also be passed in to methods that take an auth parameter instead of ex_keyname.
Maybe we could remove ex_ from the front of some of these methods?
> Add support for keypairs management in the OpenStack driver
> -----------------------------------------------------------
>
> Key: LIBCLOUD-392
> URL: https://issues.apache.org/jira/browse/LIBCLOUD-392
> Project: Libcloud
> Issue Type: Improvement
> Components: Compute
> Environment: OpenStack
> Reporter: L. Schaub
> Labels: Key, KeyPair, OpenStack, SSH, features, patch
> Original Estimate: 168h
> Remaining Estimate: 168h
>
> Add the following methods to the OpenStack driver:
> * ex_list_keypairs
> * ex_create_keypair
> * ex_delete_keypair
> A KeyPair object will also be needed.
> This object will contain the following members:
> * name
> * fingerprint
> * public_key
> * private_key (optional)
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira