You are viewing a plain text version of this content. The canonical link for it is here.
Posted to announce@tomcat.apache.org by Mark Thomas <ma...@apache.org> on 2025/05/29 19:02:28 UTC
[SECURITY] CVE-2025-46701 Apache Tomcat - CGI security constraint bypass
CVE-2025-46701 Apache Tomcat - CGI security constraint bypass
Severity: Low
Vendor: The Apache Software Foundation
Versions Affected:
Apache Tomcat 11.0.0-M1 to 11.0.6
Apache Tomcat 10.1.0-M1 to 10.1.40
Apache Tomcat 9.0.0.M1 to 9.0.104
Description:
When running on a case insensitive file system with security constraints
configured for the <code>pathInfo</code> component of a URL that mapped
to the CGI servlet, it was possible to bypass those security constraints
with a specially crafted URL.
Mitigation:
Users of the affected versions should apply one of the following
mitigations:
- Upgrade to Apache Tomcat 11.0.7 or later
- Upgrade to Apache Tomcat 10.1.41 or later
- Upgrade to Apache Tomcat 9.0.105 or later
Credit:
The vulnerability was identified by Greg K (https://github.com/gregk4sec)
History:
2025-05-29 Original advisory
References:
[1] https://tomcat.apache.org/security-11.html
[2] https://tomcat.apache.org/security-10.html
[3] https://tomcat.apache.org/security-9.html
Re: [SECURITY] CVE-2025-46701 Apache Tomcat - CGI security constraint bypass
Posted by Justin Chen <ch...@msn.com>.
Per original reports from Greg K, <code>pathInfo</code> is not the only weakness.
________________________________________
From: Mark Thomas <ma...@apache.org>
Sent: Friday, May 30, 2025 3:02
To: Tomcat Users List
Cc: announce@apache.org; announce@tomcat.apache.org; Tomcat Developers List
Subject: [SECURITY] CVE-2025-46701 Apache Tomcat - CGI security constraint bypass
CVE-2025-46701 Apache Tomcat - CGI security constraint bypass
Severity: Low
Vendor: The Apache Software Foundation
Versions Affected:
Apache Tomcat 11.0.0-M1 to 11.0.6
Apache Tomcat 10.1.0-M1 to 10.1.40
Apache Tomcat 9.0.0.M1 to 9.0.104
Description:
When running on a case insensitive file system with security constraints
configured for the <code>pathInfo</code> component of a URL that mapped
to the CGI servlet, it was possible to bypass those security constraints
with a specially crafted URL.
Mitigation:
Users of the affected versions should apply one of the following
mitigations:
- Upgrade to Apache Tomcat 11.0.7 or later
- Upgrade to Apache Tomcat 10.1.41 or later
- Upgrade to Apache Tomcat 9.0.105 or later
Credit:
The vulnerability was identified by Greg K (https://github.com/gregk4sec)
History:
2025-05-29 Original advisory
References:
[1] https://tomcat.apache.org/security-11.html
[2] https://tomcat.apache.org/security-10.html
[3] https://tomcat.apache.org/security-9.html
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org