You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Robert Muir (JIRA)" <ji...@apache.org> on 2014/12/31 01:29:13 UTC

[jira] [Updated] (LUCENE-6146) Directory.copy -> Directory.copyFrom

     [ https://issues.apache.org/jira/browse/LUCENE-6146?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Robert Muir updated LUCENE-6146:
--------------------------------
    Attachment: LUCENE-6146.patch

initial patch.

> Directory.copy -> Directory.copyFrom
> ------------------------------------
>
>                 Key: LUCENE-6146
>                 URL: https://issues.apache.org/jira/browse/LUCENE-6146
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Robert Muir
>         Attachments: LUCENE-6146.patch
>
>
> Spinoff of LUCENE-4746.
> This method is currently:
> {code}
> copy(Directory to, String src, String dest, IOContext context)
> {code}
> But it would be better to restructure this so the destination directory is the one actually being changed by the operation:
> {code}
> copyFrom(Directory from, String src, String dest, IOContext context)
> {code}
> Besides fixing the order to make sense, adding it to the name might help prevent bugs like the current TrackingDirectoryWrapper impl (used by IndexWriter to track what files are used):
> {code}
> public void copy(Directory to, String src, String dest, IOContext context) throws IOException {
>   createdFileNames.add(dest); // BUG!
>   in.copy(to, src, dest, context);
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org