You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Vinod K V (JIRA)" <ji...@apache.org> on 2008/09/19 14:48:44 UTC

[jira] Created: (HADOOP-4219) [mapred] Change TaskMemoryManager to use JvmIDs instead of TaskIDs for memory-tracking.

[mapred] Change TaskMemoryManager to use JvmIDs instead of TaskIDs for memory-tracking.
---------------------------------------------------------------------------------------

                 Key: HADOOP-4219
                 URL: https://issues.apache.org/jira/browse/HADOOP-4219
             Project: Hadoop Core
          Issue Type: Bug
          Components: mapred
            Reporter: Vinod K V


To monitor tasks, TaskMemoryManager uses taskIDs to find pidFiles of the tasks. HADOOP-249 introduced jvm re-use because of which multiple tasks can run in a single JVM, and so will share the same pid(pidFile). HADOOP-249 works on a new task by creating a symlink to the pid-file of the task that ran first in the same jvm. Also, the process(jvm) is repeatedly added and removed from monitoring when tasks(under same jvm) come and go. The symlinks and the repetitive addition/removal from monitoring can be avoided if TaskMemoryManager uses JvmIDs instead of TaskIDs.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-4219) [mapred] Change TaskMemoryManager to use JvmIDs instead of TaskIDs for memory-tracking.

Posted by "Vinod K V (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-4219?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12632673#action_12632673 ] 

Vinod K V commented on HADOOP-4219:
-----------------------------------

Also, as ddas pointed out, TaskMemoryManagerThread class should be renamed to TaskMemoryManager and TestTaskTrackerMemoryManager should also be renamed to TestTaskMemoryManager for the sake of consistency.

> [mapred] Change TaskMemoryManager to use JvmIDs instead of TaskIDs for memory-tracking.
> ---------------------------------------------------------------------------------------
>
>                 Key: HADOOP-4219
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4219
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: mapred
>            Reporter: Vinod K V
>
> To monitor tasks, TaskMemoryManager uses taskIDs to find pidFiles of the tasks. HADOOP-249 introduced jvm re-use because of which multiple tasks can run in a single JVM, and so will share the same pid(pidFile). HADOOP-249 works on a new task by creating a symlink to the pid-file of the task that ran first in the same jvm. Also, the process(jvm) is repeatedly added and removed from monitoring when tasks(under same jvm) come and go. The symlinks and the repetitive addition/removal from monitoring can be avoided if TaskMemoryManager uses JvmIDs instead of TaskIDs.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.