You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Bert Huijben <be...@qqmail.nl> on 2010/05/06 09:11:35 UTC

RE: svn commit: r941617 - in /subversion/trunk/subversion/libsvn_wc: wc-queries.sql wc_db.c wc_db.h


> -----Original Message-----
> From: julianfoad@apache.org [mailto:julianfoad@apache.org]
> Sent: donderdag 6 mei 2010 10:53
> To: commits@subversion.apache.org
> Subject: svn commit: r941617 - in /subversion/trunk/subversion/libsvn_wc:
> wc-queries.sql wc_db.c wc_db.h
> 
> Author: julianfoad
> Date: Thu May  6 08:53:11 2010
> New Revision: 941617
> 
> URL: http://svn.apache.org/viewvc?rev=941617&view=rev
> Log:
> Add a function for looking up a pristine text's SHA-1 checksum from its MD-5
> checksum - the inverse of svn_wc__db_pristine_get_md5().
> 
> * subversion/libsvn_wc/wc_db.c,
>   subversion/libsvn_wc/wc_db.h
>   (svn_wc__db_pristine_get_md5): Rename parameters in the function
> prototype
>     to match the function definition.
>   (svn_wc__db_pristine_get_sha1): New function.

I think you should make this a '_temp_' function as we should not do this conversion in 1.7.0. (But it is very useful in the intermediate state where we are now). 
Or is it needed for the commit processing via the old API?

	Bert 


Re: svn commit: r941617 - in /subversion/trunk/subversion/libsvn_wc: wc-queries.sql wc_db.c wc_db.h

Posted by Greg Stein <gs...@gmail.com>.
On Thu, May 6, 2010 at 08:13, Julian Foad <ju...@wandisco.com> wrote:
> Bert Huijben wrote:
>> > -----Original Message-----
>> > From: julianfoad@apache.org [mailto:julianfoad@apache.org]
>> > Sent: donderdag 6 mei 2010 10:53
>> > To: commits@subversion.apache.org
>> > Subject: svn commit: r941617 - in /subversion/trunk/subversion/libsvn_wc:
>> > wc-queries.sql wc_db.c wc_db.h
>> >
>> > Author: julianfoad
>> > Date: Thu May  6 08:53:11 2010
>> > New Revision: 941617
>> >
>> > URL: http://svn.apache.org/viewvc?rev=941617&view=rev
>> > Log:
>> > Add a function for looking up a pristine text's SHA-1 checksum from its MD-5
>> > checksum - the inverse of svn_wc__db_pristine_get_md5().
>> >
>> > * subversion/libsvn_wc/wc_db.c,
>> >   subversion/libsvn_wc/wc_db.h
>> >   (svn_wc__db_pristine_get_md5): Rename parameters in the function
>> > prototype
>> >     to match the function definition.
>> >   (svn_wc__db_pristine_get_sha1): New function.
>>
>> I think you should make this a '_temp_' function as we should not do
>> this conversion in 1.7.0. (But it is very useful in the intermediate
>> state where we are now).
>> Or is it needed for the commit processing via the old API?
>
> Oh, OK... I thought all the functions were considered temp until we
> review them.  Can I leave it for now as I know I'll be coming back to it
> later anyway.  I don't know yet whether it will be needed.  I'll find
> out soon when I write that old API stuff :-)

svn_wc__db_temp_* are functions that we KNOW should not be part of the
"final" API. They generally break some abstraction or perform some
work on the database in a non-ideal fashion.

Cheers,
-g

RE: svn commit: r941617 - in /subversion/trunk/subversion/libsvn_wc: wc-queries.sql wc_db.c wc_db.h

Posted by Julian Foad <ju...@wandisco.com>.
Bert Huijben wrote:
> > -----Original Message-----
> > From: julianfoad@apache.org [mailto:julianfoad@apache.org]
> > Sent: donderdag 6 mei 2010 10:53
> > To: commits@subversion.apache.org
> > Subject: svn commit: r941617 - in /subversion/trunk/subversion/libsvn_wc:
> > wc-queries.sql wc_db.c wc_db.h
> > 
> > Author: julianfoad
> > Date: Thu May  6 08:53:11 2010
> > New Revision: 941617
> > 
> > URL: http://svn.apache.org/viewvc?rev=941617&view=rev
> > Log:
> > Add a function for looking up a pristine text's SHA-1 checksum from its MD-5
> > checksum - the inverse of svn_wc__db_pristine_get_md5().
> > 
> > * subversion/libsvn_wc/wc_db.c,
> >   subversion/libsvn_wc/wc_db.h
> >   (svn_wc__db_pristine_get_md5): Rename parameters in the function
> > prototype
> >     to match the function definition.
> >   (svn_wc__db_pristine_get_sha1): New function.
> 
> I think you should make this a '_temp_' function as we should not do
> this conversion in 1.7.0. (But it is very useful in the intermediate
> state where we are now). 
> Or is it needed for the commit processing via the old API?

Oh, OK... I thought all the functions were considered temp until we
review them.  Can I leave it for now as I know I'll be coming back to it
later anyway.  I don't know yet whether it will be needed.  I'll find
out soon when I write that old API stuff :-)

- Julian