You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Karthik Kambatla (JIRA)" <ji...@apache.org> on 2016/05/17 21:19:13 UTC
[jira] [Commented] (HDFS-9782) RollingFileSystemSink should have
configurable roll interval
[ https://issues.apache.org/jira/browse/HDFS-9782?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15287586#comment-15287586 ]
Karthik Kambatla commented on HDFS-9782:
----------------------------------------
Sorry for the delay in getting to this. Looks mostly good. Some comments:
# Is the empty constructor so Reflection works?
# Javadoc for stringifySecurityProperty, findCurrentDirectory, createOrAppendLogFile, doTestGetRollInterval are broken. Mind fixing them?
# Nit: Should checkForProperty be renamed to checkIfPropertyExists for more clarity?
# RollingFileSystemSink#setInitialFlushTime is quite confusing to me. Can we clarify all the funkiness going on there? May be more comments? May be more meaningful variable name than millis?
> RollingFileSystemSink should have configurable roll interval
> ------------------------------------------------------------
>
> Key: HDFS-9782
> URL: https://issues.apache.org/jira/browse/HDFS-9782
> Project: Hadoop HDFS
> Issue Type: Improvement
> Reporter: Daniel Templeton
> Assignee: Daniel Templeton
> Attachments: HDFS-9782.001.patch, HDFS-9782.002.patch, HDFS-9782.003.patch, HDFS-9782.004.patch, HDFS-9782.005.patch, HDFS-9782.006.patch, HDFS-9782.007.patch
>
>
> Right now it defaults to rolling at the top of every hour. Instead that interval should be configurable. The interval should also allow for some play so that all hosts don't try to flush their files simultaneously.
> I'm filing this in HDFS because I suspect it will involve touching the HDFS tests. If it turns out not to, I'll move it into common instead.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org