You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@eagle.apache.org by "KuiLIU (JIRA)" <ji...@apache.org> on 2018/04/21 20:33:00 UTC

[jira] [Updated] (EAGLE-1088) Inconsistent method name

     [ https://issues.apache.org/jira/browse/EAGLE-1088?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

KuiLIU updated EAGLE-1088:
--------------------------
    Description: 
The following the method is named "find", but the method does not find anything, just returns a boolean-variable 'this.matched'. Thus, rename method as "isMatched" should be more clear than "find".

{code:java}
public boolean find() {
        return this.matched;
    }
{code}


  was:
The following the method is names "find", but the method does not find anything, just returns a boolean-variable 'this.matched'. Thus, rename method as "isMatched" should be more clear than "find".

{code:java}
public boolean find() {
        return this.matched;
    }
{code}



> Inconsistent method name
> ------------------------
>
>                 Key: EAGLE-1088
>                 URL: https://issues.apache.org/jira/browse/EAGLE-1088
>             Project: Eagle
>          Issue Type: Improvement
>            Reporter: KuiLIU
>            Priority: Major
>
> The following the method is named "find", but the method does not find anything, just returns a boolean-variable 'this.matched'. Thus, rename method as "isMatched" should be more clear than "find".
> {code:java}
> public boolean find() {
>         return this.matched;
>     }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)