You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Benjamin Mahler <bm...@apache.org> on 2018/01/08 00:57:30 UTC
Review Request 65012: Added tests to ensure that libprocess metrics
are alphabetical.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65012/
-----------------------------------------------------------
Review request for mesos, James Peach and Michael Park.
Repository: mesos
Description
-------
For human readability, we ensure that metrics are ordered
alphabetically in the JSON response.
Diffs
-----
3rdparty/libprocess/src/tests/metrics_tests.cpp bb7c9e37e5576f5b2e3ecc1a215e1edac758b254
Diff: https://reviews.apache.org/r/65012/diff/1/
Testing
-------
make check
Thanks,
Benjamin Mahler
Re: Review Request 65012: Added tests to ensure that libprocess
metrics are alphabetical.
Posted by James Peach <jp...@apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65012/#review194958
-----------------------------------------------------------
3rdparty/libprocess/src/tests/metrics_tests.cpp
Lines 298 (patched)
<https://reviews.apache.org/r/65012/#comment274060>
Can you refactor this with an array of `Counter`?
```
vector<Counter> counters = {
Counter("test/f"),
Counter("test/e"),
...
};
```
Then
```
foreach (c, counters) {
AWAIT_READY(metrics::add(c));
}
```
etc
- James Peach
On Jan. 8, 2018, 12:57 a.m., Benjamin Mahler wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/65012/
> -----------------------------------------------------------
>
> (Updated Jan. 8, 2018, 12:57 a.m.)
>
>
> Review request for mesos, James Peach and Michael Park.
>
>
> Repository: mesos
>
>
> Description
> -------
>
> For human readability, we ensure that metrics are ordered
> alphabetically in the JSON response.
>
>
> Diffs
> -----
>
> 3rdparty/libprocess/src/tests/metrics_tests.cpp bb7c9e37e5576f5b2e3ecc1a215e1edac758b254
>
>
> Diff: https://reviews.apache.org/r/65012/diff/1/
>
>
> Testing
> -------
>
> make check
>
>
> Thanks,
>
> Benjamin Mahler
>
>
Re: Review Request 65012: Added tests to ensure that libprocess
metrics are alphabetical.
Posted by James Peach <jp...@apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65012/#review194978
-----------------------------------------------------------
Ship it!
Ship It!
- James Peach
On Jan. 8, 2018, 12:57 a.m., Benjamin Mahler wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/65012/
> -----------------------------------------------------------
>
> (Updated Jan. 8, 2018, 12:57 a.m.)
>
>
> Review request for mesos, James Peach and Michael Park.
>
>
> Repository: mesos
>
>
> Description
> -------
>
> For human readability, we ensure that metrics are ordered
> alphabetically in the JSON response.
>
>
> Diffs
> -----
>
> 3rdparty/libprocess/src/tests/metrics_tests.cpp bb7c9e37e5576f5b2e3ecc1a215e1edac758b254
>
>
> Diff: https://reviews.apache.org/r/65012/diff/1/
>
>
> Testing
> -------
>
> make check
>
>
> Thanks,
>
> Benjamin Mahler
>
>