You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@hbase.apache.org by 冯宏华 <fe...@xiaomi.com> on 2012/11/28 07:07:56 UTC

答复: Best practice for the naming convention of column family

according to "http://hbase.apache.org/book.html#number.of.cfs" - "6.3.2.1. Column Families" : Try to keep the ColumnFamily names as small as possible, preferably one character (e.g. "d" for data/default).
________________________________________
发件人: Ramasubramanian Narayanan [ramasubramanian.narayanan@gmail.com]
发送时间: 2012年11月28日 13:51
收件人: user@hbase.apache.org
主题: Best practice for the naming convention of column family

Hi,

Can anyone suggest the best practice for the naming convention for the
column family pls..

regards,

Rams

Re: 答复: Best practice for the naming convention of column family

Posted by Jean-Marc Spaggiari <je...@spaggiari.org>.
Then on your code, just refer to it as a constant, like:
public static final byte[] CF_COLUMN_NAME = Bytes.toBytes("d");

On all your calls you will then use CF_COLUMN_NAME...

JM

2012/11/28, 冯宏华 <fe...@xiaomi.com>:
> according to "http://hbase.apache.org/book.html#number.of.cfs" - "6.3.2.1.
> Column Families" : Try to keep the ColumnFamily names as small as possible,
> preferably one character (e.g. "d" for data/default).
> ________________________________________
> 发件人: Ramasubramanian Narayanan [ramasubramanian.narayanan@gmail.com]
> 发送时间: 2012年11月28日 13:51
> 收件人: user@hbase.apache.org
> 主题: Best practice for the naming convention of column family
>
> Hi,
>
> Can anyone suggest the best practice for the naming convention for the
> column family pls..
>
> regards,
>
> Rams
>