You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@uima.apache.org by "James Zhu (JIRA)" <de...@uima.apache.org> on 2015/05/09 01:28:01 UTC

[jira] [Comment Edited] (UIMA-3374) A new mode for annotation viewer based on feature values

    [ https://issues.apache.org/jira/browse/UIMA-3374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14535871#comment-14535871 ] 

James Zhu edited comment on UIMA-3374 at 5/8/15 11:27 PM:
----------------------------------------------------------

This patch needs to be applied to uimaj-tools project only. Functional-wise, it is still exactly the same as before. In this patch, I have included the following:

1. Cosmetic changes to replace tabs with spaces.
2. Added null checks and checks against array sizes etc.
3. Initialize private variables only when needed. Added various reset methods to reset collections of check boxes etc when view mode changes.
4. (line 237 - 264) Created sub panel to hold the "Select All"/"Deselect All"/"Show/Hide Unselected" buttons (existing and showing), and sub panel for the Sofa selection combo box (existing and currently hidden and used to live in the same panel as the select buttons), and sub panel for the view modes (currently hidden and used to live in the same panel as the select buttons).
5. (line 280 - 309) Minor improvement so that if the view mode radio buttons are shown in the future, repeatedly clicking on the same view mode radio button will NOT cause the screen to re-render. Current behavior is screen re-renders with every click.
6. (line 326 - 335) Minor improvement so that if the sofa selection combobox is shown in the future, repeatedly selecting the same sofa will NOT cause the screen to re-render. Current behavior is screen re-renders with every click.
7. Refactor setCAS() method into smaller methods.
8. Refactored display() related methods to improve readability. Now it is easier to understand how checkboxes are created and added/removed from the panel in different view modes.
9. Augmented the logic with isMatch() method so that in Entities view we can also determine whether mouse selected entities should be shown in the tree view. (line 1380, 1400 - 1423)
10. Refactored addFeatureTreeNodes() method by extracting a helper method getFeatureValueInString(). So it is easier to understand how features of an annotation is rendered in the tree view.
11. Other misc refactoring to break long methods into smaller ones.

Please let me know if you have trouble following any of these changes.

In next patch, I will start to introduce code changes for the new "feature" view mode, and we will start seeing functional enhancements.   


was (Author: jichun):
This patch needs to be applied to uimaj-tools project only. Functional-wise, it is still exactly the same as before. In this patch, I have included the following:

1. Cosmetic changes to replace tabs with spaces.
2. Added null checks and checks against array sizes etc.
3. Initialize private variables only when needed. Added reset method to reset collections of check boxes etc when view mode changes.
4. (line 237 - 264) Created sub panel to hold the "Select All"/"Deselect All"/"Show/Hide Unselected" buttons (existing and showing), and sub panel for the Sofa selection combo box (existing and currently hidden and used to live in the same panel as the select buttons), and sub panel for the view modes (currently hidden and used to live in the same panel as the select buttons).
5. (line 280 - 309) Minor improvement so that if the view mode radio buttons are shown in the future, repeatedly clicking on the same view mode radio button will NOT cause the screen to re-render. Current behavior is screen re-renders with every click.
6. (line 326 - 335) Minor improvement so that if the sofa selection combobox is shown in the future, repeatedly selecting the same sofa will NOT cause the screen to re-render. Current behavior is screen re-renders with every click.
7. Refactor setCAS() method into smaller methods.
8. Refactored display() related methods to improve readability. Now it is easier to understand how checkboxes are created and added/removed from the panel in different view modes.
9. Augmented the logic with isMatch() method so that in Entities view we can also determine whether mouse selected entities should be shown in the tree view. (line 1380, 1400 - 1423)
10. Refactored addFeatureTreeNodes() method by extracting a helper method getFeatureValueInString(). So it is easier to understand how features of an annotation is rendered in the tree view.
11. Other misc refactoring to break long methods into smaller ones.

Please let me know if you have trouble following any of these changes.

In next patch, I will start to introduce code changes for the new "feature" view mode, and we will start seeing functional enhancements.   

> A new mode for annotation viewer based on feature values
> --------------------------------------------------------
>
>                 Key: UIMA-3374
>                 URL: https://issues.apache.org/jira/browse/UIMA-3374
>             Project: UIMA
>          Issue Type: Improvement
>          Components: InternalTools
>    Affects Versions: 2.5.0SDK
>            Reporter: James Zhu
>            Assignee: Marshall Schor
>            Priority: Minor
>              Labels: annotation, feature, filter, type, value, viewer
>         Attachments: UIMA-3374 patch 2015-04-21.txt, UIMA-3374 patch 2015-04-23.txt, UIMA-3374 patch 2015-04-28.txt, UIMA-3374 patch 2015-05-08.txt, screenshot-1.jpg, screenshot-2.jpg, screenshot-3.jpg, screenshot-4.jpg
>
>   Original Estimate: 504h
>  Remaining Estimate: 504h
>
> I'd like to propose adding a new "view mode" in the UIMA Annotation Viewer so that user can pick a specific type of annotations, and then pick a specific feature, and pick specific feature values available so user can see a subset of those annotation objects that have the specific feature values.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)