You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by gi...@apache.org on 2023/12/13 12:24:37 UTC
(httpcomponents-core) branch dependabot/maven/io.reactivex.rxjava3-rxjava-3.1.8 updated (2cd5d259f -> 9e79d10be)
This is an automated email from the ASF dual-hosted git repository.
github-bot pushed a change to branch dependabot/maven/io.reactivex.rxjava3-rxjava-3.1.8
in repository https://gitbox.apache.org/repos/asf/httpcomponents-core.git
discard 2cd5d259f Bump io.reactivex.rxjava3:rxjava from 3.1.6 to 3.1.8
add 371347add HTTPCLIENT-2298: Strict connection pool to filter out expired and completed requests from the pool stats
add 0d4aeb557 Add security warning to TrustStrategy documentation (#438)
add faaa82fb7 HTTPCORE-762: H2 protocol handler incorrectly determines the maximum frame size for outgoing frames in case the remote endpoint negotiated a max frame size larger than the protocol default
add c5a530166 Updated release notes for HttpCore 5.2.4 release
add d1c77bc7f Upgraded HttpCore version to 5.2.5-SNAPSHOT
add 83ca33b12 Upgraded HttpCore version to 5.3-alpha1-SNAPSHOT
add 1aefde37e Added ViaRequest interceptor.
add a85aebdbc Fix the issue with invalid scoped IPv6 addresses in InetAddressUtils.
add 2696f7aa7 Use either US-ASCII or UTF-8 encoding for text where approriate
add 5e760235d Add a "Forwarded" HttpRequestInterceptor to add the "Forwarded" HTTP header.
add a024494de Add support for Internationalized Domain Names (IDN)
add 557b03684 Use Timeout#INFINITE instead of Timeout#DISABLED for network operations
add 2dbb880e0 Return emptySet or emptyList instead of null to honor contract for return type
add 4dd956341 HTTPCORE-744: removed references to URI normalization from URIBuilder; deprecated URIBuilder#normalizeSyntax
add d735e3b6e Refactor Synchronized Blocks to Use ReentrantLock. (#412)
add 903eadd05 Refactor testConcurrentOperations to use AtomicBooleans for outcome verification, enhancing test determinism and reducing exception unpredictability. (#419)
add b4e6a3780 Async requesters to support custom / resolved target endpoints
add 600fa3d25 Async requesters to populate request URI authority based on the target host when not explicitly set by the caller
add f529ead65 HTTPCORE-756 - Deprecate and remove userInfo from URIAuthority and URIBuilder in compliance with RFC 9110. (#418)
add f8721abbc HTTPCORE-756 - Enforced non-empty host identifier for http/https URIs. (#423)
add 286442bf7 HTTPCORE-756 - Implement RFC9110 Content-Type validation for OPTIONS requests. Enforce the presence of a valid Content-Type header for OPTIONS requests containing content, as per RFC9110. (#424)
add 843c20347 Refactor testGetWithTimeout for Reliability (#426)
add a0ad6f21c Implement RFC 7540 :path Pseudo-Header Validation for HTTP/2 Requests (#428)
add bc2eb85a3 Improved name/value parsing code
add c687bbfb2 Message support improvements
add e453a8110 HTTPCORE-759: Add Content-Length to POST, PUT and PATCH with null entity request content (#435)
add 7e5879db1 HTTPCORE-756: server-side request / response protocol conformance checks (#434)
add d1f1e33bd HTTPCORE-756: replace CR, LF, NULL in header values with SP per RFC 9110 section 5.5
add 353b7aaac HTTPCORE-756: reject HTTPS requests received over insecure (non-TLS) connection per RFC 9110 section 7.4
add 584aecdd3 HTTPCORE-756: support methods for handling hop-by-hop and connection specific headers (ported from HttpClient cache module)
add 755ebef1f More message support methods
add 181d70834 HTTPCORE-756: Expect-Continue handshake improvements per RFC 9110 section 10.1.1 * ignore Expect header in requests older than HTTP/1.1 * Servers to respond with 417 in case of unexpected Expect token
add 799d0cdd0 HTTPCORE-756: Updated response status codes as per RFC 9110 section 18.3
add a2d88f428 HTTPCORE-756: Better name for the standard date pattern
add a61b16031 Javadoc improvements (no functional changes)
add 0ff85f765 HTTPCORE-756: client protocol handlers to try to send `Host` as the first header in the request header section per RFC 9110 section 7.2
add 64a6ced2f HTTPCORE-756: Authority from an absolute request URI to take precedence over Host header per RFC 9112 section 3.2
add 51f3be8b9 HTTPCORE-756: Support for the effective HTTP/1.x protocol level config parameter; HTTP/1.1 endpoints to signal their actual supported protocol level (the minor version in HTTP/1.x) in the message control data as per RFC 9110 section 6.2
add b4d6016f2 Fixed deprecation warnings
add 1fef3f985 HTTPCORE-756: Stricter parsing of response status code per RFC 9112 section 3.2; less intermediate garbage while parsing response status lines
add 7fea9ef7f HTTPCORE-756: Improved Transfer-Encoding handling and message frame validity verification per RFC 9112 section 6.1
add e5ba6e1fa Support for percent coding as defined in RFC 5987
add c6fa1f8de Bump actions/checkout from 3 to 4
add 6eec9472c Bump log4j.version from 2.19.0 to 2.22.0
add eef0f52b5 Bump org.junit:junit-bom from 5.9.1 to 5.10.1
add 9e79d10be Bump io.reactivex.rxjava3:rxjava from 3.1.6 to 3.1.8
This update added new revisions after undoing existing revisions.
That is to say, some revisions that were in the old version of the
branch are not in the new version. This situation occurs
when a user --force pushes a change and generates a repository
containing something like this:
* -- * -- B -- O -- O -- O (2cd5d259f)
\
N -- N -- N refs/heads/dependabot/maven/io.reactivex.rxjava3-rxjava-3.1.8 (9e79d10be)
You should already have received notification emails for all of the O
revisions, and so the following emails describe only the N revisions
from the common base, B.
Any revisions marked "omit" are not gone; other references still
refer to them. Any revisions marked "discard" are gone forever.
No new revisions were added by this update.
Summary of changes:
.github/workflows/codeql-analysis.yml | 2 +-
.github/workflows/depsreview.yaml | 2 +-
.github/workflows/maven.yml | 2 +-
RELEASE_NOTES.txt | 17 +
httpcore5-h2/pom.xml | 2 +-
.../http2/impl/DefaultH2RequestConverter.java | 37 ++
.../apache/hc/core5/http2/impl/H2Processors.java | 10 +-
.../impl/nio/AbstractH2StreamMultiplexer.java | 2 +-
.../http2/impl/nio/ServerH2StreamHandler.java | 1 -
.../nio/bootstrap/H2MultiplexingRequester.java | 72 +++-
.../impl/nio/bootstrap/H2ServerBootstrap.java | 4 +-
.../core5/http2/protocol/H2RequestConnControl.java | 4 +
.../hc/core5/http2/protocol/H2RequestContent.java | 7 +
.../core5/http2/protocol/H2RequestTargetHost.java | 4 +
.../http2/protocol/H2RequestValidateHost.java | 4 +
.../http2/protocol/H2ResponseConnControl.java | 4 +
.../hc/core5/http2/protocol/H2ResponseContent.java | 4 +
.../hc/core5/http2/examples/H2GreetingServer.java | 2 +-
.../http2/impl/TestDefaultH2RequestConverter.java | 95 +++++
.../core5/http2/protocol/TestH2Interceptors.java | 145 ++++++++
httpcore5-reactive/pom.xml | 2 +-
.../hc/core5/reactive/ReactiveDataConsumer.java | 9 +-
.../hc/core5/reactive/ReactiveDataProducer.java | 19 +-
.../hc/core5/reactive/ReactiveEntityProducer.java | 3 +-
.../core5/reactive/TestReactiveEntityProducer.java | 5 +-
httpcore5-testing/pom.xml | 2 +-
.../org/apache/hc/core5/testing/SocksProxy.java | 65 ++--
.../core5/testing/classic/ClassicTestClient.java | 2 +-
.../InternalServerHttp1EventHandlerFactory.java | 2 +-
.../testing/classic/ClassicIntegrationTest.java | 68 ++--
.../testing/framework/TestTestingFramework.java | 27 --
.../hc/core5/testing/nio/Http1IntegrationTest.java | 80 ++---
httpcore5/pom.xml | 2 +-
.../apache/hc/core5/concurrent/BasicFuture.java | 74 ++--
.../main/java/org/apache/hc/core5/http/Chars.java | 1 +
.../java/org/apache/hc/core5/http/ContentType.java | 18 +-
.../java/org/apache/hc/core5/http/HttpStatus.java | 121 +++----
.../hc/core5/http/config/CharCodingConfig.java | 8 +-
.../apache/hc/core5/http/config/Http1Config.java | 39 +-
.../hc/core5/http/impl/BasicEntityDetails.java | 3 +-
.../hc/core5/http/impl/DefaultAddressResolver.java | 6 +-
.../http/impl/DefaultConnectionReuseStrategy.java | 41 ++-
.../http/impl/DefaultContentLengthStrategy.java | 30 +-
.../http/impl/EnglishReasonPhraseCatalog.java | 6 +-
.../apache/hc/core5/http/impl/HttpProcessors.java | 14 +-
.../apache/hc/core5/http/impl/ServerSupport.java | 16 -
.../core5/http/impl/bootstrap/AsyncRequester.java | 13 +
.../http/impl/bootstrap/AsyncServerBootstrap.java | 6 +-
.../http/impl/bootstrap/HttpAsyncRequester.java | 51 ++-
.../core5/http/impl/bootstrap/HttpRequester.java | 2 +-
.../http/impl/bootstrap/RequesterBootstrap.java | 13 +-
.../core5/http/impl/bootstrap/ServerBootstrap.java | 3 +-
.../core5/http/impl/io/AbstractMessageParser.java | 21 +-
.../hc/core5/http/impl/io/BHttpConnectionBase.java | 6 +-
.../http/impl/io/DefaultBHttpClientConnection.java | 10 +-
.../io/DefaultBHttpClientConnectionFactory.java | 6 +-
.../http/impl/io/DefaultBHttpServerConnection.java | 2 +-
.../io/DefaultBHttpServerConnectionFactory.java | 6 +-
.../http/impl/io/DefaultHttpRequestParser.java | 30 +-
.../impl/io/DefaultHttpRequestParserFactory.java | 32 +-
.../http/impl/io/DefaultHttpRequestWriter.java | 33 +-
.../impl/io/DefaultHttpRequestWriterFactory.java | 23 +-
.../http/impl/io/DefaultHttpResponseParser.java | 28 +-
.../impl/io/DefaultHttpResponseParserFactory.java | 32 +-
.../http/impl/io/DefaultHttpResponseWriter.java | 33 +-
.../impl/io/DefaultHttpResponseWriterFactory.java | 23 +-
.../hc/core5/http/impl/io/HttpRequestExecutor.java | 42 ++-
.../apache/hc/core5/http/impl/io/HttpService.java | 50 ++-
.../http/impl/nio/AbstractHttp1StreamDuplexer.java | 20 +-
.../core5/http/impl/nio/AbstractMessageParser.java | 37 +-
.../impl/nio/ClientHttp1StreamDuplexerFactory.java | 4 +-
.../http/impl/nio/ClientHttp1StreamHandler.java | 16 +-
.../http/impl/nio/DefaultHttpRequestParser.java | 45 ++-
.../impl/nio/DefaultHttpRequestParserFactory.java | 2 +-
.../http/impl/nio/DefaultHttpRequestWriter.java | 29 +-
.../impl/nio/DefaultHttpRequestWriterFactory.java | 23 +-
.../http/impl/nio/DefaultHttpResponseParser.java | 39 +-
.../impl/nio/DefaultHttpResponseParserFactory.java | 2 +-
.../http/impl/nio/DefaultHttpResponseWriter.java | 29 +-
.../impl/nio/DefaultHttpResponseWriterFactory.java | 23 +-
.../http/impl/nio/ServerHttp1StreamDuplexer.java | 36 +-
.../impl/nio/ServerHttp1StreamDuplexerFactory.java | 4 +-
.../http/impl/nio/ServerHttp1StreamHandler.java | 15 +-
.../hc/core5/http/io/HttpMessageParserFactory.java | 8 +
.../org/apache/hc/core5/http/io/SocketConfig.java | 2 +-
.../hc/core5/http/io/entity/EntityUtils.java | 14 +-
.../hc/core5/http/io/entity/StringEntity.java | 4 +-
.../BasicHttpServerExpectationDecorator.java | 13 +-
.../io/support/HttpServerExpectationFilter.java | 16 +-
.../hc/core5/http/message/BasicHeaderElement.java | 2 +-
.../core5/http/message/BasicHeaderValueParser.java | 23 +-
.../hc/core5/http/message/BasicHttpRequest.java | 3 +-
.../hc/core5/http/message/BasicLineParser.java | 29 +-
.../hc/core5/http/message/BufferedHeader.java | 25 +-
.../hc/core5/http/message/MessageSupport.java | 391 ++++++++++++++++++---
.../nio/entity/AbstractBinAsyncEntityProducer.java | 27 +-
.../entity/AbstractCharAsyncEntityProducer.java | 25 +-
.../http/nio/entity/AbstractCharDataConsumer.java | 4 +-
.../http/nio/entity/BasicAsyncEntityProducer.java | 5 +-
.../core5/http/nio/entity/FileEntityProducer.java | 3 +-
.../core5/http/nio/entity/PathEntityProducer.java | 3 +-
.../nio/support/AsyncServerExpectationFilter.java | 32 +-
.../AbstractClassicServerExchangeHandler.java | 3 +-
.../hc/core5/http/protocol/ForwardedRequest.java | 185 ++++++++++
.../hc/core5/http/protocol/HttpDateGenerator.java | 39 +-
...uestTargetHost.java => RequestConformance.java} | 57 ++-
.../hc/core5/http/protocol/RequestConnControl.java | 11 +-
.../hc/core5/http/protocol/RequestContent.java | 50 ++-
.../apache/hc/core5/http/protocol/RequestDate.java | 9 +-
.../core5/http/protocol/RequestExpectContinue.java | 9 +-
.../hc/core5/http/protocol/RequestTargetHost.java | 10 +-
.../hc/core5/http/protocol/RequestUserAgent.java | 7 +-
.../core5/http/protocol/RequestValidateHost.java | 16 +-
...{ResponseDate.java => ResponseConformance.java} | 30 +-
.../core5/http/protocol/ResponseConnControl.java | 13 +-
.../hc/core5/http/protocol/ResponseContent.java | 13 +-
.../hc/core5/http/protocol/ResponseDate.java | 11 +-
.../hc/core5/http/protocol/ResponseServer.java | 7 +-
.../hc/core5/http/protocol/UriPatternMatcher.java | 72 ++--
.../http/protocol/UriPatternOrderedMatcher.java | 61 +++-
.../hc/core5/http/protocol/UriRegexMatcher.java | 57 ++-
.../apache/hc/core5/http/protocol/ViaRequest.java | 127 +++++++
.../core5/http/support/AbstractRequestBuilder.java | 2 +-
.../hc/core5/http/support/ExpectSupport.java | 71 ++++
.../Lookup.java => support/Expectation.java} | 14 +-
.../main/java/org/apache/hc/core5/net/Host.java | 23 +-
.../org/apache/hc/core5/net/InetAddressUtils.java | 28 +-
.../java/org/apache/hc/core5/net/PercentCodec.java | 70 +++-
.../java/org/apache/hc/core5/net/URIAuthority.java | 59 ++--
.../java/org/apache/hc/core5/net/URIBuilder.java | 68 ++--
.../java/org/apache/hc/core5/pool/LaxConnPool.java | 9 +-
.../org/apache/hc/core5/pool/StrictConnPool.java | 26 +-
.../hc/core5/reactor/AbstractIOSessionPool.java | 36 +-
.../core5/reactor/AbstractSingleCoreIOReactor.java | 31 +-
.../apache/hc/core5/reactor/IOReactorConfig.java | 2 +-
.../org/apache/hc/core5/reactor/IOSessionImpl.java | 4 +-
.../core5/reactor/SocksProxyProtocolHandler.java | 2 +
.../org/apache/hc/core5/ssl/SSLContextBuilder.java | 5 +
.../org/apache/hc/core5/ssl/TrustStrategy.java | 13 +
.../java/org/apache/hc/core5/util/TextUtils.java | 18 +
.../java/org/apache/hc/core5/util/Timeout.java | 19 +
.../hc/core5/concurrent/TestBasicFuture.java | 103 +++++-
...tionExample.java => AsyncClientSNIExample.java} | 89 +++--
.../http/examples/AsyncReverseProxyExample.java | 100 +++++-
...onExample.java => ClassicClientSNIExample.java} | 40 ++-
.../http/examples/ClassicPostExecutionExample.java | 2 +-
.../impl/TestDefaultConnectionReuseStrategy.java | 10 +
.../impl/TestDefaultContentLengthStrategy.java | 46 ++-
.../http/impl/io/TestBHttpConnectionBase.java | 6 +-
.../hc/core5/http/impl/io/TestChunkCoding.java | 48 +--
.../http/impl/io/TestContentLengthInputStream.java | 8 +-
.../http/impl/io/TestSessionInOutBuffers.java | 6 +-
.../hc/core5/http/io/entity/TestEntityUtils.java | 32 +-
.../http/io/entity/TestHttpEntityWrapper.java | 2 +-
.../http/io/entity/TestInputStreamEntity.java | 20 +-
.../hc/core5/http/io/entity/TestStringEntity.java | 6 +-
.../core5/http/message/HttpRequestWrapperTest.java | 6 +-
.../message/TestBasicHeaderValueFormatter.java | 8 +-
.../http/message/TestBasicHeaderValueParser.java | 10 +-
.../hc/core5/http/message/TestBasicLineParser.java | 6 +
.../hc/core5/http/message/TestBasicMessages.java | 6 +-
.../hc/core5/http/message/TestBufferedHeader.java | 22 ++
.../hc/core5/http/message/TestMessageSupport.java | 263 +++++++++++++-
.../support/classic/TestSharedOutputBuffer.java | 45 ++-
.../core5/http/protocol/TesForwardedRequest.java | 196 +++++++++++
.../http/protocol/TestStandardInterceptors.java | 137 +++++++-
.../hc/core5/http/protocol/ViaRequestTest.java | 117 ++++++
.../http/support/TestBasicMessageBuilders.java | 8 +
.../hc/core5/http/support/TestExpectSupport.java | 110 ++++++
.../java/org/apache/hc/core5/net/TestHost.java | 11 +
.../apache/hc/core5/net/TestInetAddressUtils.java | 18 +
.../org/apache/hc/core5/net/TestPercentCodec.java | 30 ++
.../org/apache/hc/core5/net/TestURIAuthority.java | 81 ++---
.../org/apache/hc/core5/net/TestURIBuilder.java | 80 +++--
.../org/apache/hc/core5/ssl/DummyProvider.java | 13 +-
pom.xml | 10 +-
176 files changed, 4320 insertions(+), 1163 deletions(-)
create mode 100644 httpcore5-h2/src/test/java/org/apache/hc/core5/http2/protocol/TestH2Interceptors.java
create mode 100644 httpcore5/src/main/java/org/apache/hc/core5/http/protocol/ForwardedRequest.java
copy httpcore5/src/main/java/org/apache/hc/core5/http/protocol/{RequestTargetHost.java => RequestConformance.java} (58%)
copy httpcore5/src/main/java/org/apache/hc/core5/http/protocol/{ResponseDate.java => ResponseConformance.java} (69%)
create mode 100644 httpcore5/src/main/java/org/apache/hc/core5/http/protocol/ViaRequest.java
create mode 100644 httpcore5/src/main/java/org/apache/hc/core5/http/support/ExpectSupport.java
copy httpcore5/src/main/java/org/apache/hc/core5/http/{config/Lookup.java => support/Expectation.java} (83%)
copy httpcore5/src/test/java/org/apache/hc/core5/http/examples/{AsyncRequestExecutionExample.java => AsyncClientSNIExample.java} (60%)
copy httpcore5/src/test/java/org/apache/hc/core5/http/examples/{ClassicGetExecutionExample.java => ClassicClientSNIExample.java} (75%)
create mode 100644 httpcore5/src/test/java/org/apache/hc/core5/http/protocol/TesForwardedRequest.java
create mode 100644 httpcore5/src/test/java/org/apache/hc/core5/http/protocol/ViaRequestTest.java
create mode 100644 httpcore5/src/test/java/org/apache/hc/core5/http/support/TestExpectSupport.java