You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "Ted Yu (JIRA)" <ji...@apache.org> on 2017/12/04 14:42:00 UTC

[jira] [Created] (KAFKA-6307) mBeanName should be removed before returning from JmxReporter#removeAttribute()

Ted Yu created KAFKA-6307:
-----------------------------

             Summary: mBeanName should be removed before returning from JmxReporter#removeAttribute()
                 Key: KAFKA-6307
                 URL: https://issues.apache.org/jira/browse/KAFKA-6307
             Project: Kafka
          Issue Type: Bug
            Reporter: Ted Yu


JmxReporter$KafkaMbean showed up near the top in the first histo output from KAFKA-6199.
In JmxReporter#removeAttribute() :
{code}
        KafkaMbean mbean = this.mbeans.get(mBeanName);
        if (mbean != null)
            mbean.removeAttribute(metricName.name());
        return mbean;
{code}
mbeans.remove(mBeanName) should be called before returning.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)