You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@trafficserver.apache.org by "Leif Hedstrom (JIRA)" <ji...@apache.org> on 2010/10/31 00:53:22 UTC

[jira] Created: (TS-504) Add plugin APIs to allow for Transaction "private" data

Add plugin APIs to allow for Transaction "private" data
-------------------------------------------------------

                 Key: TS-504
                 URL: https://issues.apache.org/jira/browse/TS-504
             Project: Traffic Server
          Issue Type: New Feature
          Components: InkAPI
            Reporter: Leif Hedstrom


This is similar to the existing INKHttpTxnSetArg() / INKHttpTxnGetArg() APIs, except we should use an identifier for the data similar to TS-503. E.g.

INKReturnCode INKTxnDataSet(INKHttpTxn txnp, int64 id, void* data);
void* INKTxnnDataGet(INKHttpTxn txnp, int64 id);

The difference is that a) these IDs are unique, and registered via the same API as used for INKSsnDataSet() and b) they do not have a limit on the number of entities / data that we can store.

Once this is done, the old SetArg / GetArg() APIs should be deprecated.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (TS-504) Add plugin APIs to allow for Transaction "private" data

Posted by "Leif Hedstrom (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/TS-504?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12933186#action_12933186 ] 

Leif Hedstrom commented on TS-504:
----------------------------------

Looking at this some more, I think what we really should do is add two additional APIs:

int InkHttpArgIndexReserve(const char* name, const char* description);

and

int InkHttpArgIndexGet(const char* name, const char** description);

These two methods would register / Get the index as used by both the TXN and SSN private arg data (i.e. one API reserves the same index for both transaction and session args).

Also, I wonder if we should normalize the Set/Get APIs, to be inline with all other naming conventions? I.e.

INKHttpTxnArgSet()
INKHttpTxnArgGet()

> Add plugin APIs to allow for Transaction "private" data
> -------------------------------------------------------
>
>                 Key: TS-504
>                 URL: https://issues.apache.org/jira/browse/TS-504
>             Project: Traffic Server
>          Issue Type: New Feature
>          Components: TSAPI
>            Reporter: Leif Hedstrom
>            Assignee: Leif Hedstrom
>             Fix For: 2.1.5
>
>
> This is similar to the existing INKHttpTxnSetArg() / INKHttpTxnGetArg() APIs, except we should use an identifier for the data similar to TS-503. E.g.
> INKReturnCode INKTxnDataSet(INKHttpTxn txnp, int64 id, void* data);
> void* INKTxnnDataGet(INKHttpTxn txnp, int64 id);
> The difference is that a) these IDs are unique, and registered via the same API as used for INKSsnDataSet() and b) they do not have a limit on the number of entities / data that we can store.
> Once this is done, the old SetArg / GetArg() APIs should be deprecated.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (TS-504) Add plugin APIs to allow for Transaction "private" data

Posted by "Leif Hedstrom (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/TS-504?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Leif Hedstrom updated TS-504:
-----------------------------

    Fix Version/s: 2.1.5

> Add plugin APIs to allow for Transaction "private" data
> -------------------------------------------------------
>
>                 Key: TS-504
>                 URL: https://issues.apache.org/jira/browse/TS-504
>             Project: Traffic Server
>          Issue Type: New Feature
>          Components: InkAPI
>            Reporter: Leif Hedstrom
>             Fix For: 2.1.5
>
>
> This is similar to the existing INKHttpTxnSetArg() / INKHttpTxnGetArg() APIs, except we should use an identifier for the data similar to TS-503. E.g.
> INKReturnCode INKTxnDataSet(INKHttpTxn txnp, int64 id, void* data);
> void* INKTxnnDataGet(INKHttpTxn txnp, int64 id);
> The difference is that a) these IDs are unique, and registered via the same API as used for INKSsnDataSet() and b) they do not have a limit on the number of entities / data that we can store.
> Once this is done, the old SetArg / GetArg() APIs should be deprecated.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (TS-504) Add plugin APIs to allow for Transaction "private" data

Posted by "Leif Hedstrom (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/TS-504?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Leif Hedstrom resolved TS-504.
------------------------------

    Resolution: Fixed

> Add plugin APIs to allow for Transaction "private" data
> -------------------------------------------------------
>
>                 Key: TS-504
>                 URL: https://issues.apache.org/jira/browse/TS-504
>             Project: Traffic Server
>          Issue Type: New Feature
>          Components: TSAPI
>            Reporter: Leif Hedstrom
>            Assignee: Leif Hedstrom
>             Fix For: 2.1.5
>
>
> This is similar to the existing INKHttpTxnSetArg() / INKHttpTxnGetArg() APIs, except we should use an identifier for the data similar to TS-503. E.g.
> INKReturnCode INKTxnDataSet(INKHttpTxn txnp, int64 id, void* data);
> void* INKTxnnDataGet(INKHttpTxn txnp, int64 id);
> The difference is that a) these IDs are unique, and registered via the same API as used for INKSsnDataSet() and b) they do not have a limit on the number of entities / data that we can store.
> Once this is done, the old SetArg / GetArg() APIs should be deprecated.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.