You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hive.apache.org by Vaibhav Gumashta <vg...@hortonworks.com> on 2018/01/22 20:29:39 UTC

Review Request 65271: JDBC: Provide a way for JDBC users to pass cookie info via connection string

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65271/
-----------------------------------------------------------

Review request for hive and Thejas Nair.


Bugs: HIVE-18447
    https://issues.apache.org/jira/browse/HIVE-18447


Repository: hive-git


Description
-------

https://issues.apache.org/jira/browse/HIVE-18447


Diffs
-----

  itests/hive-unit/src/test/java/org/apache/hive/service/cli/thrift/TestThriftHttpCLIServiceFeatures.java 1911d2ce17 
  jdbc/src/java/org/apache/hive/jdbc/HiveConnection.java b5d289e023 
  jdbc/src/java/org/apache/hive/jdbc/HttpBasicAuthInterceptor.java 8cb7a69df7 
  jdbc/src/java/org/apache/hive/jdbc/HttpKerberosRequestInterceptor.java 3509cab775 
  jdbc/src/java/org/apache/hive/jdbc/HttpRequestInterceptorBase.java 68b0ff19b8 
  jdbc/src/java/org/apache/hive/jdbc/HttpTokenAuthInterceptor.java 207ed9e663 
  jdbc/src/java/org/apache/hive/jdbc/Utils.java 1c1f644c92 


Diff: https://reviews.apache.org/r/65271/diff/1/


Testing
-------


Thanks,

Vaibhav Gumashta


Re: Review Request 65271: JDBC: Provide a way for JDBC users to pass cookie info via connection string

Posted by Thejas Nair <th...@hortonworks.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65271/#review196636
-----------------------------------------------------------




jdbc/src/java/org/apache/hive/jdbc/HttpRequestInterceptorBase.java
Line 91 (original), 96 (patched)
<https://reviews.apache.org/r/65271/#comment276342>

    A nit - 
    I think using "+=" is more readable for appends -
    
    cookieHeaderKeyValues +=
                   ";" + entry.getKey() + "=" + entry.getValue();


- Thejas Nair


On Jan. 31, 2018, 10:50 p.m., Vaibhav Gumashta wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/65271/
> -----------------------------------------------------------
> 
> (Updated Jan. 31, 2018, 10:50 p.m.)
> 
> 
> Review request for hive and Thejas Nair.
> 
> 
> Bugs: HIVE-18447
>     https://issues.apache.org/jira/browse/HIVE-18447
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> https://issues.apache.org/jira/browse/HIVE-18447
> 
> 
> Diffs
> -----
> 
>   itests/hive-unit/src/test/java/org/apache/hive/service/cli/thrift/TestThriftHttpCLIServiceFeatures.java 93b10fb4b4 
>   jdbc/src/java/org/apache/hive/jdbc/HiveConnection.java cb2f09cbf2 
>   jdbc/src/java/org/apache/hive/jdbc/HttpBasicAuthInterceptor.java 5d2ddb5c21 
>   jdbc/src/java/org/apache/hive/jdbc/HttpKerberosRequestInterceptor.java 37862be804 
>   jdbc/src/java/org/apache/hive/jdbc/HttpRequestInterceptorBase.java cf1a11ecb6 
>   jdbc/src/java/org/apache/hive/jdbc/HttpTokenAuthInterceptor.java 59a91dd14c 
>   jdbc/src/java/org/apache/hive/jdbc/Utils.java f7f3854b86 
> 
> 
> Diff: https://reviews.apache.org/r/65271/diff/2/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Vaibhav Gumashta
> 
>


Re: Review Request 65271: JDBC: Provide a way for JDBC users to pass cookie info via connection string

Posted by Vaibhav Gumashta <vg...@hortonworks.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65271/
-----------------------------------------------------------

(Updated Jan. 31, 2018, 10:50 p.m.)


Review request for hive and Thejas Nair.


Bugs: HIVE-18447
    https://issues.apache.org/jira/browse/HIVE-18447


Repository: hive-git


Description
-------

https://issues.apache.org/jira/browse/HIVE-18447


Diffs (updated)
-----

  itests/hive-unit/src/test/java/org/apache/hive/service/cli/thrift/TestThriftHttpCLIServiceFeatures.java 93b10fb4b4 
  jdbc/src/java/org/apache/hive/jdbc/HiveConnection.java cb2f09cbf2 
  jdbc/src/java/org/apache/hive/jdbc/HttpBasicAuthInterceptor.java 5d2ddb5c21 
  jdbc/src/java/org/apache/hive/jdbc/HttpKerberosRequestInterceptor.java 37862be804 
  jdbc/src/java/org/apache/hive/jdbc/HttpRequestInterceptorBase.java cf1a11ecb6 
  jdbc/src/java/org/apache/hive/jdbc/HttpTokenAuthInterceptor.java 59a91dd14c 
  jdbc/src/java/org/apache/hive/jdbc/Utils.java f7f3854b86 


Diff: https://reviews.apache.org/r/65271/diff/2/

Changes: https://reviews.apache.org/r/65271/diff/1-2/


Testing
-------


Thanks,

Vaibhav Gumashta