You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@geode.apache.org by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2021/09/13 17:45:00 UTC

[jira] [Commented] (GEODE-9585) Add support for the KEYSLOT command

    [ https://issues.apache.org/jira/browse/GEODE-9585?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17414441#comment-17414441 ] 

ASF subversion and git services commented on GEODE-9585:
--------------------------------------------------------

Commit d0c734f7d1313a27ea9a6361e8c7e07ac872d127 in geode's branch refs/heads/develop from Dan Smith
[ https://gitbox.apache.org/repos/asf?p=geode.git;h=d0c734f ]

GEODE-9585: adding support for the KEYSLOT command

Adding support for the keyslot command. refactoring the RedisKey code a little
bit to move the slot calculation into a static method that can be used and
tested separately. Changing RedisKey.crc16 to slot, because that is only thing
we are using the crc16 field for.

Changing the implementation of slotForKey to more closely mirror the logic of
the native redis keyHashSlot method. This reproduces the same behavior as
native redis with malformed hashtags with unmatched parens.

Adding more test cases including a junit quick check case.

Co-authored-by: Eric Zoerner <zo...@vmware.com>

> Add support for the KEYSLOT command
> -----------------------------------
>
>                 Key: GEODE-9585
>                 URL: https://issues.apache.org/jira/browse/GEODE-9585
>             Project: Geode
>          Issue Type: Improvement
>          Components: redis
>            Reporter: Dan Smith
>            Assignee: Dan Smith
>            Priority: Major
>              Labels: pull-request-available
>
> Spring data redis's JedisClusterKeyCommands class unfortunately is calling the CLUSTER KEYSLOT command on the server to find the slot for a key when performing rename or restore operations. Rename is used by spring session data redis.
> I'll file a PR against jedis, but in the meantime we should add support for the KEYSLOT command to handle this and other weird client behaviors.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)