You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Eli Collins (JIRA)" <ji...@apache.org> on 2010/05/01 07:34:54 UTC

[jira] Updated: (HADOOP-6585) Add FileStatus#isDirectory and isFile

     [ https://issues.apache.org/jira/browse/HADOOP-6585?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Eli Collins updated HADOOP-6585:
--------------------------------

    Attachment: hadoop-6585-2.patch

Patch attached merges with trunk. Also:

* Added missing rename test FileContextSymlinkBaseTest#testRenameFileWithDestParentSymlink that covers renaming a file to a path dst where the parent of dst is a symlink (eg rename dir/file to link/file for all types of link).
* Made FileContextSymlinkBaseTest check more specific instances of caught exceptions
* Remove unused checks for null in AFS#renameInternal, AFS#getFile*Status should never return null

Will run hudson now that all the dependencies for this change are checked in.

> Add FileStatus#isDirectory and isFile
> -------------------------------------
>
>                 Key: HADOOP-6585
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6585
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>    Affects Versions: 0.21.0, 0.22.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>            Priority: Blocker
>             Fix For: 0.21.0, 0.22.0
>
>         Attachments: hadoop-6585-1.patch, hadoop-6585-2.patch
>
>
> Per Sanjay's suggestion in HADOOP-6421 let's deprecate FileStatus#isDir() and add isDirectory() and isFile() to compliment isSymlink. Currently clients assume !isDir() implies a file, which is no longer true with symlinks. I'll file a separate jira to change the various uses of !isDir() to be isFile() or isFile() or isSymlink() as appropriate.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.