You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@pekko.apache.org by he...@apache.org on 2026/04/18 10:21:52 UTC

(pekko) branch fixTypo created (now abff61ec37)

This is an automated email from the ASF dual-hosted git repository.

He-Pin pushed a change to branch fixTypo
in repository https://gitbox.apache.org/repos/asf/pekko.git


      at abff61ec37 fix: rename shudownLatch to shutdownLatch in ScatterGatherSpec

This branch includes the following new commits:

     new abff61ec37 fix: rename shudownLatch to shutdownLatch in ScatterGatherSpec

The 1 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.



---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@pekko.apache.org
For additional commands, e-mail: commits-help@pekko.apache.org


(pekko) 01/01: fix: rename shudownLatch to shutdownLatch in ScatterGatherSpec

Posted by he...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

He-Pin pushed a commit to branch fixTypo
in repository https://gitbox.apache.org/repos/asf/pekko.git

commit abff61ec37e4b10f28ea98cff3fff6ea6ff3b3aa
Author: He-Pin <he...@gmail.com>
AuthorDate: Sat Apr 18 18:21:34 2026 +0800

    fix: rename shudownLatch to shutdownLatch in ScatterGatherSpec
    
    Motivation:
    Typo in variable name `shudownLatch` should be `shutdownLatch`.
    
    Modification:
    Renamed `shudownLatch` to `shutdownLatch` in
    ScatterGatherFirstCompletedSpec (parameter and usage).
    
    Result:
    Correct spelling, no functional change. All tests pass.
    
    🤖 Generated with [Qoder][https://qoder.com]
---
 .../org/apache/pekko/routing/ScatterGatherFirstCompletedSpec.scala    | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/actor-tests/src/test/scala/org/apache/pekko/routing/ScatterGatherFirstCompletedSpec.scala b/actor-tests/src/test/scala/org/apache/pekko/routing/ScatterGatherFirstCompletedSpec.scala
index a9d56b11ee..6902fab230 100644
--- a/actor-tests/src/test/scala/org/apache/pekko/routing/ScatterGatherFirstCompletedSpec.scala
+++ b/actor-tests/src/test/scala/org/apache/pekko/routing/ScatterGatherFirstCompletedSpec.scala
@@ -34,7 +34,7 @@ object ScatterGatherFirstCompletedSpec {
 
   final case class Stop(id: Option[Int] = None)
 
-  def newActor(id: Int, shudownLatch: Option[TestLatch] = None)(implicit system: ActorSystem) =
+  def newActor(id: Int, shutdownLatch: Option[TestLatch] = None)(implicit system: ActorSystem) =
     system.actorOf(
       Props(new Actor {
         def receive = {
@@ -48,7 +48,7 @@ object ScatterGatherFirstCompletedSpec {
         }
 
         override def postStop() = {
-          shudownLatch.foreach(_.countDown())
+          shutdownLatch.foreach(_.countDown())
         }
       }),
       "Actor:" + id)


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@pekko.apache.org
For additional commands, e-mail: commits-help@pekko.apache.org