You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "Chia-Ping Tsai (Jira)" <ji...@apache.org> on 2024/07/31 16:52:00 UTC
[jira] [Updated] (KAFKA-16899) Rename MembershipManagerImpl's rebalanceTimeoutMs for clarity
[ https://issues.apache.org/jira/browse/KAFKA-16899?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Chia-Ping Tsai updated KAFKA-16899:
-----------------------------------
Fix Version/s: 4.0.0
(was: 3.9.0)
> Rename MembershipManagerImpl's rebalanceTimeoutMs for clarity
> -------------------------------------------------------------
>
> Key: KAFKA-16899
> URL: https://issues.apache.org/jira/browse/KAFKA-16899
> Project: Kafka
> Issue Type: Improvement
> Components: clients, consumer
> Affects Versions: 3.8.0
> Reporter: Kirk True
> Assignee: Linu Shibu
> Priority: Minor
> Labels: kip-848-client-support
> Fix For: 4.0.0
>
>
> The naming of {{{}MembershipManagerImpl{}}}'s {{rebalanceTimeoutMs}} is a little confusing.
> Ultimately the broker enforces the rebalance process' timeout, not the client. It's therefore a little misleading to use {{rebalanceTimeoutMs}} as the name of a variable that only handles the client's commit portion of the process. It is used in {{MembershipManagerImpl}} as a means to limit the client's efforts in the case where it is repeatedly trying to commit but failing.
> A suggested name change was {{{}commitTimeoutDuringReconciliation{}}}.
> It is not clear to me that simply changing the name from {{rebalanceTimeoutMs}} to {{commitTimeoutDuringReconciliation}} is sufficient. When a caller instantiates a {{{}MembershipManagerImpl{}}}, it is passing in a variable named {{rebalanceTimeoutMs}} that ultimately comes from the {{ClientConfig}} object. I can imagine it being a little confusing that a value for {{rebalanceTimeoutMs}} is passed in, but then really only used as the value for {{commitTimeoutDuringReconciliation}}.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)