You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@karaf.apache.org by Jean-Baptiste Onofré <jb...@nanthrax.net> on 2011/01/02 13:24:22 UTC
Re: adding aries jndi, transaction and persistence features to myinstance
A simpler way is to create your own feature descriptor. We do it in ServiceMix.
Regards
JB
-----Original Message-----
From: Andreas Pieber <an...@gmail.com>
Date: Sun, 2 Jan 2011 10:54:49
To: <us...@karaf.apache.org>
Reply-To: user@karaf.apache.org
Subject: Re: adding aries jndi, transaction and persistence features to my
instance
Hey Ivanhoe,
The problem is that the 2.1.99-SNAPSHOT version of the features.xml is also
"made" for the 2.2.0 karaf release. The simplest solution would be to use the
karaf trunk. Everything should work there. We plan to release 2.2.0 asap as
aries 1.0.0 is out (janurary). I don't think that we'll upgrade aries in the
2.1.x branch...
Is using trunk (karaf-2.2.0) a solution for you? Otherwise I'm afraid you have
to maintain your own version of karaf-2.1.x to get rid of aries 0.2.0.
kind regards,
andreas
On Sun, Jan 02, 2011 at 11:55:33AM +0200, Ivanhoe Abrahams wrote:
> Hi
>
> I am in the process of adding aries transaction, jndi and persistence
> to my karaf instance
>
> To achieve this I downloaded the aries source code and built it
> locally.
>
> I also downloaded the enterprise-2.1.99-SNAPSHOT-features features file
> and am trying to run the features:install transaction command (btw I
> also tried persistence and jndi)
>
> However if I do the above I get the following error
>
> karaf@root> features:install transaction
> Error executing command: Invalid value: (obr)))
>
> I then went and changed the feature xml file and removed the following
> attribute .... resolver='(obr)'
>
> After that change I get the following error
>
> karaf@root> features:install transaction
> Error executing command: Could not start bundle
> mvn:org.apache.aries.transaction/org.apache.aries.transaction.blueprint
> /0.3-SNAPSHOT in feature(s) : Unresolved constraint in bundle
> [1]org.apache.aries.tr
> ansaction.blueprint [187]: Unable to resolve 187.0: missing requirement
> [187.0] package;
> (&(package=org.apache.aries.blueprint)(version>=0.3.0)(!(version>=1.0.0
> )))
>
> I am assuming that this is because the aries version that is bundled
> with karaf is only at version 0.2.0 incubating
>
> So my question is
>
> Is it possible to upgrade the karaf-bundled version of aries to 0.3.0?
> I wouldnt want to have both the old version and 0.3.0 installed, that
> seems unneccessary
>
> otherwise, what do others do to install the latest enterprise aries
> features?
>
> Thankyou in advance
>
> Regards
>
> Ivanhoe
>
> References
>
> 1. http://org.apache.aries.tr/
Re: adding aries jndi, transaction and persistence features to myinstance
Posted by Ivanhoe Abrahams <iv...@gmail.com>.
Hi Jean-Baptiste
Thanks for the hint,
PS. I assume I can find the mentioned feature descriptor in the servicemix
svn repo.
Also, is there some kind of central repository for karaf feature
descriptors? I do find them handy but even handier would be a repository of
features
regards
Ivanhoe
On Sun, Jan 2, 2011 at 2:24 PM, Jean-Baptiste Onofré <jb...@nanthrax.net>wrote:
> A simpler way is to create your own feature descriptor. We do it in
> ServiceMix.
>
> Regards
> JB
> -----Original Message-----
> From: Andreas Pieber <an...@gmail.com>
> Date: Sun, 2 Jan 2011 10:54:49
> To: <us...@karaf.apache.org>
> Reply-To: user@karaf.apache.org
> Subject: Re: adding aries jndi, transaction and persistence features to my
> instance
>
> Hey Ivanhoe,
>
> The problem is that the 2.1.99-SNAPSHOT version of the features.xml is also
> "made" for the 2.2.0 karaf release. The simplest solution would be to use
> the
> karaf trunk. Everything should work there. We plan to release 2.2.0 asap as
> aries 1.0.0 is out (janurary). I don't think that we'll upgrade aries in
> the
> 2.1.x branch...
>
> Is using trunk (karaf-2.2.0) a solution for you? Otherwise I'm afraid you
> have
> to maintain your own version of karaf-2.1.x to get rid of aries 0.2.0.
>
> kind regards,
> andreas
>
> On Sun, Jan 02, 2011 at 11:55:33AM +0200, Ivanhoe Abrahams wrote:
> > Hi
> >
> > I am in the process of adding aries transaction, jndi and persistence
> > to my karaf instance
> >
> > To achieve this I downloaded the aries source code and built it
> > locally.
> >
> > I also downloaded the enterprise-2.1.99-SNAPSHOT-features features
> file
> > and am trying to run the features:install transaction command (btw I
> > also tried persistence and jndi)
> >
> > However if I do the above I get the following error
> >
> > karaf@root> features:install transaction
> > Error executing command: Invalid value: (obr)))
> >
> > I then went and changed the feature xml file and removed the following
> > attribute .... resolver='(obr)'
> >
> > After that change I get the following error
> >
> > karaf@root> features:install transaction
> > Error executing command: Could not start bundle
> >
> mvn:org.apache.aries.transaction/org.apache.aries.transaction.blueprint
> > /0.3-SNAPSHOT in feature(s) : Unresolved constraint in bundle
> > [1]org.apache.aries.tr
> > ansaction.blueprint [187]: Unable to resolve 187.0: missing
> requirement
> > [187.0] package;
> >
> (&(package=org.apache.aries.blueprint)(version>=0.3.0)(!(version>=1.0.0
> > )))
> >
> > I am assuming that this is because the aries version that is bundled
> > with karaf is only at version 0.2.0 incubating
> >
> > So my question is
> >
> > Is it possible to upgrade the karaf-bundled version of aries to 0.3.0?
> > I wouldnt want to have both the old version and 0.3.0 installed, that
> > seems unneccessary
> >
> > otherwise, what do others do to install the latest enterprise aries
> > features?
> >
> > Thankyou in advance
> >
> > Regards
> >
> > Ivanhoe
> >
> > References
> >
> > 1. http://org.apache.aries.tr/
>
>