You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Mason Bryant (JIRA)" <ji...@apache.org> on 2010/07/01 01:46:50 UTC

[jira] Updated: (CASSANDRA-1204) CliClient Support for add, drop, and rename should be added for keyspace and column family

     [ https://issues.apache.org/jira/browse/CASSANDRA-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Mason Bryant updated CASSANDRA-1204:
------------------------------------

    Attachment: cli_unit_tests.diff

Also:

Unit tests.

I'm not sure they are suitable for inclusion because they depend on a running Cassandra Server at localhost and expect a couple of keyspaces to not be present (it does a bunch of creating, modifying, and dropping of those keyspace so if they did exist, they'd be destroyed in the testing so the tests just fail if they are present).

They were useful for my work on the cli, so here they are.

> CliClient Support for add, drop, and rename should be added for keyspace and column family
> ------------------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-1204
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-1204
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 0.7
>            Reporter: Mason Bryant
>            Priority: Minor
>             Fix For: 0.7
>
>         Attachments: cli_new_methods2.diff, cli_new_methods3.diff, cli_unit_tests.diff
>
>
> Should add support for the add, drop, and rename operations to keyspace and column family in the CliClient.
> Eg:
> add keyspace <keyspace>                                      Add a new keyspace.
> add column family <cf>[comparator]                      Add a new column family.
> drop keyspace <keyspace>                                      Delete a keyspace.
> drop column family <cf>                                  Delete a column family.
> rename keyspace <keyspace>=<keyspace_new_name>                Rename a keyspace.
> rename column family <name>=<new_name>                   Rename a column family.
> Note: I have patch built for this, but drop keyspace corrupts the schema and prevents the node from restarting due to a bug elsewhere (see: CASSANDRA-1203)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.