You are viewing a plain text version of this content. The canonical link for it is here.
Posted to woden-dev@ws.apache.org by "John Kaputin (JIRA)" <ji...@apache.org> on 2007/12/14 22:32:43 UTC

[jira] Commented: (WODEN-47) Represent component extension properties with generic collections, rather than static subtyping of the ComponentExtensions interface

    [ https://issues.apache.org/jira/browse/WODEN-47?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12551945 ] 

John Kaputin commented on WODEN-47:
-----------------------------------

r604298
First code change for this JIRA was to implement better consistency in the naming conventions used for static constants. In particular, for constants that define namespaces and other types of URIs either using java.net.URI or java.lang.String. 

The new convention is purpose_javatype_otherinfo. For example:

NS_STRING_WSDL20 =  "http://www.w3.org/ns/wsdl";
NS_URI_WSDL20 = URI.create(NS_STRING_WSDL20);

> Represent component extension properties with generic collections, rather than static subtyping of the ComponentExtensions interface
> ------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: WODEN-47
>                 URL: https://issues.apache.org/jira/browse/WODEN-47
>             Project: Woden
>          Issue Type: Improvement
>          Components: Parser
>            Reporter: John Kaputin
>            Assignee: John Kaputin
>             Fix For: M8
>
>
> Feedback at Apachecon Europe indicates that the way Woden represents extension properties in the Component model via static subtyping of the ComponentExtensions interface is not useful for client applications like WSDL tools or wizards which need to list or access WSDL and extensions properties that the components contain and should ideally do so without specific knowledge of any extension types. They should be able to just retrieve collections of properties to display in a GUI or whatever.
> This proposal will remove the need to statically  subtype the ComponentExtensions interface to represent extension properties for a particular namespace and WSDL component and instead, represent extension properties in the Component API as some form of generic 'extension property'  (or maybe just a 'component property') and add appropriate getter methods to the API for accessing these properties. The terms 'extension property' or 'component property' should not be confused with the Property component described in the WSDL Component model spec. 
> For client applications that do require or expect particular extension properties, this proposal should not impose any new obligations on the client code. The client must still 'know' what it's looking for, but instead of using a static API determined by a ComponentExtensions subtype it will use these new generic getter methods to retrieve and filter the extension properties it requires. This proposal just removes compile time type safety in favour of runtime time flexibility.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: woden-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: woden-dev-help@ws.apache.org