You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "ASF GitHub Bot (Jira)" <ji...@apache.org> on 2019/08/24 08:28:00 UTC

[jira] [Updated] (FLINK-13832) DefaultRollingPolicy create() method should be renamed to builder()

     [ https://issues.apache.org/jira/browse/FLINK-13832?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

ASF GitHub Bot updated FLINK-13832:
-----------------------------------
    Labels: pull-request-available  (was: )

> DefaultRollingPolicy create() method should be renamed to builder()
> -------------------------------------------------------------------
>
>                 Key: FLINK-13832
>                 URL: https://issues.apache.org/jira/browse/FLINK-13832
>             Project: Flink
>          Issue Type: Improvement
>          Components: Connectors / FileSystem
>    Affects Versions: 1.9.0
>            Reporter: Gyula Fora
>            Assignee: Gyula Fora
>            Priority: Minor
>              Labels: pull-request-available
>
> The  DefaultRollingPolicy.create() method returns an instance of PolicyBuilder not a DefaultRollingPolicy.  Therefore we should add a new method named .builder() and deprecate "create".
> Right now if we want to create a new instance with the default settings we have to call:
> DefaultRollingPolicy.create().build()
> This nicely illustrates the problem with the naming of this method.



--
This message was sent by Atlassian Jira
(v8.3.2#803003)