You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@james.apache.org by rc...@apache.org on 2024/09/04 09:49:51 UTC
(james-project) 10/20: [Antora] Adapt after partial - JAMES-3824 SMTP Extension for Message Transfer Priorities
This is an automated email from the ASF dual-hosted git repository.
rcordier pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/james-project.git
commit 34a91abf13849455d6e6db61ff043565c7b1107e
Author: Tung Tran <vt...@linagora.com>
AuthorDate: Fri Aug 30 08:47:09 2024 +0700
[Antora] Adapt after partial - JAMES-3824 SMTP Extension for Message Transfer Priorities
Adapt commit: 57ccc5a1882d9ecdb2b0497b14c751dddf42869c
---
.../partials/architecture/implemented-standards.adoc | 2 +-
.../servers/partials/configure/smtp-hooks.adoc | 19 +++++++++++++++++++
2 files changed, 20 insertions(+), 1 deletion(-)
diff --git a/docs/modules/servers/partials/architecture/implemented-standards.adoc b/docs/modules/servers/partials/architecture/implemented-standards.adoc
index 707c1bcc7a..5a338bc06e 100644
--- a/docs/modules/servers/partials/architecture/implemented-standards.adoc
+++ b/docs/modules/servers/partials/architecture/implemented-standards.adoc
@@ -34,7 +34,7 @@ This page details standards implemented by the {server-name}.
- link:https://datatracker.ietf.org/doc/html/rfc2142[RFC-2142] Mailbox Names For Common Services, Roles And Functions
- link:https://datatracker.ietf.org/doc/html/rfc2197[RFC-2197] SMTP Service Extension for Command Pipelining
- link:https://datatracker.ietf.org/doc/html/rfc2554[RFC-2554] ESMTP Service Extension for Authentication
-- link:https://datatracker.ietf.org/doc/html/rfc1893[RFC-1893] Enhanced Mail System Status Codes
+- link:https://datatracker.ietf.org/doc/rfc6710/[RFC-6710] SMTP Extension for Message Transfer Priorities
== LMTP
diff --git a/docs/modules/servers/partials/configure/smtp-hooks.adoc b/docs/modules/servers/partials/configure/smtp-hooks.adoc
index a660051a1d..5744849845 100644
--- a/docs/modules/servers/partials/configure/smtp-hooks.adoc
+++ b/docs/modules/servers/partials/configure/smtp-hooks.adoc
@@ -329,6 +329,25 @@ The {server-name} has optional support for FUTURERELEASE (link:https://www.rfc-e
</smtpserver>
....
+== Message Transfer Priorities hooks
+
+The Distributed server has optional support for SMTP Extension for Message Transfer Priorities (link:https://www.rfc-editor.org/rfc/rfc6710.html[RFC-6710])
+
+The SMTP server changes the priority of the message from -9 to -1 as 0 according to the implemented mail priority support policy.
+The SMTP server does not allow positive priorities from unauthorized sources and sets the priority to the default value (0).
+
+....
+<smtpserver enabled="true">
+ <...> <!-- The rest of your SMTP configuration, unchanged -->
+ <handlerchain>
+ <handler class="org.apache.james.smtpserver.priority.SmtpMtPriorityEhloHook"/>
+ <handler class="org.apache.james.smtpserver.priority.SmtpMtPriorityParameterHook"/>
+ <handler class="org.apache.james.smtpserver.priority.SmtpMtPriorityMessageHook"/>
+ <handler class="org.apache.james.smtpserver.CoreCmdHandlerLoader"/>
+ </handlerchain>
+</smtpserver>
+....
+
== DKIM checks hooks
Hook for verifying DKIM signatures of incoming mails.
---------------------------------------------------------------------
To unsubscribe, e-mail: notifications-unsubscribe@james.apache.org
For additional commands, e-mail: notifications-help@james.apache.org