You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "stack (Commented) (JIRA)" <ji...@apache.org> on 2012/02/24 05:53:48 UTC

[jira] [Commented] (HBASE-5451) Switch RPC call envelope/headers to PBs

    [ https://issues.apache.org/jira/browse/HBASE-5451?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13215378#comment-13215378 ] 

stack commented on HBASE-5451:
------------------------------

Excellent!

Minor, would do:

 if (!head.hasUserInfo()) return;

.. Then you'd save an indent of the whole body of the method.

Seems like ticket should be renamed user (we seem to be creating a user rather than a ticket?) here -- I like the way you ask user to create passing the header:

-      ticket = header.getUser();
+      ticket = User.create(header);

Is ConnectionContext actually the headers?  Should it be called ConnectionHeader?

What is this -- HBaseCompleteRpcRequestProto?  Its 'The complete RPC request message'.  Its the callid and the client request.  Is it the complete request because its missing the header?  Should it just be called Request since its inside a package that makes its provinence clear?  I suppose request would be odd because you then do getRequest on it... hmm.

Why tunnelRequest.  Whats that mean?

I like the builder stuff making headers and request over in client.

Fatten doc on the proto file I'd say.  Its going to be our spec.

Can these proto classes drop the HBaseRPC prefix?  Is the Proto suffix going to be our convention denoting Proto classes going forward?

Are we doing to repeat the hrpc exception handling carrying Strings for exceptions from server to client?



                
> Switch RPC call envelope/headers to PBs
> ---------------------------------------
>
>                 Key: HBASE-5451
>                 URL: https://issues.apache.org/jira/browse/HBASE-5451
>             Project: HBase
>          Issue Type: Sub-task
>          Components: ipc, master, migration, regionserver
>            Reporter: Todd Lipcon
>            Assignee: Devaraj Das
>         Attachments: rpc-proto.patch.1_2
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira