You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@nifi.apache.org by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2021/01/19 18:26:00 UTC

[jira] [Commented] (NIFI-8146) Allow RecordPath to be used for specifying operation type and data fields when using PutDatabaseRecord

    [ https://issues.apache.org/jira/browse/NIFI-8146?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17268121#comment-17268121 ] 

ASF subversion and git services commented on NIFI-8146:
-------------------------------------------------------

Commit f02079c2faa008c9d2a5fc0cebafcb398c22bf0c in nifi's branch refs/heads/main from Mark Payne
[ https://gitbox.apache.org/repos/asf?p=nifi.git;h=f02079c ]

NIFI-8146: Added RecordPath for Statement Type and to specify where to find the data within the incoming Record. Also performed some minor code refactoring to avoid lots of large lambdas, as it results in code that is more readable and more maintainable. Updated some properties to use dependsOn() notation now that this is available.

NIFI-8146: Updated PutDatabaseRecord to avoid using the functional style framework that had previously been used. Doing so resulted in code that was difficult to understand and maintain. Added additional unit tests and improved MockRecordParser so that it could throw configurable types of exceptions

NIFI-8146: Fixed checkstyle issues

Signed-off-by: Matthew Burgess <ma...@apache.org>

This closes #4763


> Allow RecordPath to be used for specifying operation type and data fields when using PutDatabaseRecord
> ------------------------------------------------------------------------------------------------------
>
>                 Key: NIFI-8146
>                 URL: https://issues.apache.org/jira/browse/NIFI-8146
>             Project: Apache NiFi
>          Issue Type: New Feature
>          Components: Extensions
>            Reporter: Mark Payne
>            Assignee: Mark Payne
>            Priority: Major
>          Time Spent: 0.5h
>  Remaining Estimate: 0h
>
> PutDatbaseRecord requires that the Statement Type be defined as a property or a FlowFile attribute. This means that if a FlowFile has many records, it must be split apart into individual Records if there is more than 1 type of statement needed per FlowFile.
> It also assumes that the data to be inserted/updated/deleted/etc is the full record. However, it's common to have some wrapper around the actual data, as is the case with a tool like Debezium, which includes an Operation Type, a 'before' snapshot and an 'after' snapshot. To accommodate this, we should allow Record-friendly methods for specifying the path to the data and the operation type. 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)