You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@stdcxx.apache.org by "Martin Sebor (JIRA)" <ji...@apache.org> on 2005/09/27 23:40:50 UTC

[jira] Created: (STDCXX-43) names of atomic functions inconsitent

names of atomic functions inconsitent
-------------------------------------

         Key: STDCXX-43
         URL: http://issues.apache.org/jira/browse/STDCXX-43
     Project: STDCXX
        Type: Improvement
  Components: Build  
    Versions: 4.1.2    
 Environment: all
    Reporter: Martin Sebor
     Fix For: 4.1.3


The names of the implementation-specific atomic functions are inconsistent: some contain the width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()), and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()). This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(), etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (STDCXX-43) names of atomic functions inconsitent

Posted by "Martin Sebor (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/STDCXX-43?page=all ]

Martin Sebor updated STDCXX-43:
-------------------------------

    Fix Version: 4.1.4
                     (was: 4.1.3)

> names of atomic functions inconsitent
> -------------------------------------
>
>          Key: STDCXX-43
>          URL: http://issues.apache.org/jira/browse/STDCXX-43
>      Project: STDCXX
>         Type: Improvement
>   Components: Build
>     Versions: 4.1.2
>  Environment: all
>     Reporter: Martin Sebor
>     Assignee: Martin Sebor
>      Fix For: 4.1.4

>
> The names of the implementation-specific atomic functions are inconsistent: some contain the width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()), and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()). This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(), etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (STDCXX-43) names of atomic functions inconsitent

Posted by "Martin Sebor (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/STDCXX-43?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Martin Sebor updated STDCXX-43:
-------------------------------

    Priority: Trivial  (was: Major)

This is purely cosmetic. Lowered priority.

> names of atomic functions inconsitent
> -------------------------------------
>
>                 Key: STDCXX-43
>                 URL: https://issues.apache.org/jira/browse/STDCXX-43
>             Project: C++ Standard Library
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 4.1.2
>         Environment: all
>            Reporter: Martin Sebor
>            Assignee: Martin Sebor
>            Priority: Trivial
>             Fix For: 4.2
>
>
> The names of the implementation-specific atomic functions are inconsistent: some contain the width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()), and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()). This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(), etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Assigned: (STDCXX-43) names of atomic functions inconsitent

Posted by "Martin Sebor (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/STDCXX-43?page=all ]

Martin Sebor reassigned STDCXX-43:
----------------------------------

    Assign To: Martin Sebor

> names of atomic functions inconsitent
> -------------------------------------
>
>          Key: STDCXX-43
>          URL: http://issues.apache.org/jira/browse/STDCXX-43
>      Project: STDCXX
>         Type: Improvement
>   Components: Build
>     Versions: 4.1.2
>  Environment: all
>     Reporter: Martin Sebor
>     Assignee: Martin Sebor
>      Fix For: 4.1.3

>
> The names of the implementation-specific atomic functions are inconsistent: some contain the width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()), and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()). This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(), etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (STDCXX-43) names of atomic functions inconsitent

Posted by "Martin Sebor (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/STDCXX-43?page=all ]

Martin Sebor updated STDCXX-43:
-------------------------------

    Fix Version: 4.2
                     (was: 4.1.4)

> names of atomic functions inconsitent
> -------------------------------------
>
>          Key: STDCXX-43
>          URL: http://issues.apache.org/jira/browse/STDCXX-43
>      Project: C++ Standard Library
>         Type: Improvement

>   Components: Build
>     Versions: 4.1.2
>  Environment: all
>     Reporter: Martin Sebor
>     Assignee: Martin Sebor
>      Fix For: 4.2

>
> The names of the implementation-specific atomic functions are inconsistent: some contain the width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()), and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()). This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(), etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (STDCXX-43) names of atomic functions inconsitent

Posted by "Martin Sebor (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/STDCXX-43?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Martin Sebor updated STDCXX-43:
-------------------------------

    Fix Version/s:     (was: 4.2)
                   4.2.1

This is mostly done but not complete. Deferred until 4.2.1.

> names of atomic functions inconsitent
> -------------------------------------
>
>                 Key: STDCXX-43
>                 URL: https://issues.apache.org/jira/browse/STDCXX-43
>             Project: C++ Standard Library
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 4.1.2
>         Environment: all
>            Reporter: Martin Sebor
>            Assignee: Martin Sebor
>            Priority: Trivial
>             Fix For: 4.2.1
>
>
> The names of the implementation-specific atomic functions are inconsistent: some contain the width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()), and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()). This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(), etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.