You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ofbiz.apache.org by "Tom Burns (Created) (JIRA)" <ji...@apache.org> on 2012/04/17 18:37:17 UTC

[jira] [Created] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

eCommerce Profile Improve Button Naming Consistency
---------------------------------------------------

                 Key: OFBIZ-4822
                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
             Project: OFBiz
          Issue Type: Improvement
          Components: specialpurpose/ecommerce
    Affects Versions: SVN trunk
         Environment: demo-trunk
            Reporter: Tom Burns
            Priority: Minor
             Fix For: SVN trunk


This follows from OFBIZ-4814 bug fix.

In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
Example:
Changes Password label should be "Go Back" but is "[Go Back]"


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

Posted by "Jacques Le Roux (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/OFBIZ-4822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13256676#comment-13256676 ] 

Jacques Le Roux commented on OFBIZ-4822:
----------------------------------------

Tom,

authview quickly fixed for now at r1327562
Interesting:
{quote}
That said the authview is used inconsistently in eCommerce and only in the ftl files in the Customer folder.
It calls the authview request in the controller which sets https before calling main view.
The donePage call is set to viewprofile, which sets https, from all of the edit forms off viewprofile.
So authview does not appear to be adding any value. The code would be clearer without it.
{quote}

I tend to agree from what yo are saying (no review I mean). Would you mind to provide a patch to remove it, did you test it?

{quote}
It is not completely clear to me where donePage is picking up is value.
{quote}
I had a look before committing, since this is in the profile screen, and at the top of it there is a call to the editperson screen, then it's intially set there with default-value="viewprofile"

I agree with your 3 points, good catches. I saw also that you put the buttons at top and bottom where they were missing (maybe it was you say in point 3. BTW...)
                
> eCommerce Profile Improve Button Naming Consistency
> ---------------------------------------------------
>
>                 Key: OFBIZ-4822
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: specialpurpose/ecommerce
>    Affects Versions: SVN trunk
>         Environment: demo-trunk
>            Reporter: Tom Burns
>            Assignee: Jacques Le Roux
>            Priority: Minor
>             Fix For: SVN trunk
>
>         Attachments: OFBIZ-4822 eCommerce Profile GoBack Improvement.patch
>
>
> This follows from OFBIZ-4814 bug fix.
> In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
> Example:
> Changes Password label should be "Go Back" but is "[Go Back]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

Posted by "Tom Burns (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-4822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Tom Burns updated OFBIZ-4822:
-----------------------------

    Attachment: OFBIZ-4822 eCommerce Profile GoBack Improvement.patch
    
> eCommerce Profile Improve Button Naming Consistency
> ---------------------------------------------------
>
>                 Key: OFBIZ-4822
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: specialpurpose/ecommerce
>    Affects Versions: SVN trunk
>         Environment: demo-trunk
>            Reporter: Tom Burns
>            Assignee: Jacques Le Roux
>            Priority: Minor
>             Fix For: SVN trunk
>
>         Attachments: OFBIZ-4822 eCommerce Profile GoBack Improvement.patch
>
>
> This follows from OFBIZ-4814 bug fix.
> In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
> Example:
> Changes Password label should be "Go Back" but is "[Go Back]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

Posted by "Jacques Le Roux (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/OFBIZ-4822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13255922#comment-13255922 ] 

Jacques Le Roux commented on OFBIZ-4822:
----------------------------------------

Tom,

double checking I found
{code}
Modified: ofbiz/trunk/specialpurpose/ecommerce/webapp/ecommerce/customer/changepassword.ftl
URL: http://svn.apache.org/viewvc/ofbiz/trunk/specialpurpose/ecommerce/webapp/ecommerce/customer/changepassword.ftl?rev=1327269&r1=1327268&r2=1327269&view=diff
==============================================================================
--- ofbiz/trunk/specialpurpose/ecommerce/webapp/ecommerce/customer/changepassword.ftl (original)
+++ ofbiz/trunk/specialpurpose/ecommerce/webapp/ecommerce/customer/changepassword.ftl Tue Apr 17 20:12:11 2012
@@ -17,9 +17,10 @@ specific language governing permissions 
 under the License.
 -->
 <div class="screenlet">
-  <h2>${uiLabelMap.PartyChangePassword}</h2>
-  <a href="<@o...@ofbizUrl>" class="button">[${uiLabelMap.CommonGoBack}]</a>
-  <a href="javascript:document.getElementById('changepasswordform').submit()" class="button">[${uiLabelMap.CommonSave}]</a>
+  <h2>${uiLabelMap.PartyChangePassword}</h2>  
+  &nbsp;<a href="<@o...@ofbizUrl>" class="button">${uiLabelMap.CommonGoBack}</a>
+  &nbsp;<a href="javascript:document.getElementById('changepasswordform').submit()" class="button">${uiLabelMap.CommonSave}</a>
{code}

I guess the authview/ removing was not intended, right?
                
> eCommerce Profile Improve Button Naming Consistency
> ---------------------------------------------------
>
>                 Key: OFBIZ-4822
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: specialpurpose/ecommerce
>    Affects Versions: SVN trunk
>         Environment: demo-trunk
>            Reporter: Tom Burns
>            Assignee: Jacques Le Roux
>            Priority: Minor
>             Fix For: SVN trunk
>
>         Attachments: OFBIZ-4822 eCommerce Profile GoBack Improvement.patch
>
>
> This follows from OFBIZ-4814 bug fix.
> In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
> Example:
> Changes Password label should be "Go Back" but is "[Go Back]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

Posted by "Tom Burns (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/OFBIZ-4822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13256611#comment-13256611 ] 

Tom Burns commented on OFBIZ-4822:
----------------------------------

Jacques,

I did not intentionally remove it. 
Likely it was a sloppy cut an paste of the "Go Back" line from one of the other files.

That said the authview is used inconsistently in eCommerce and only in the ftl files in the Customer folder.
It calls the authview request in the controller which sets https before calling main view.
The donePage call is set to viewprofile, which sets https, from all of the edit forms off viewprofile.
So authview does not appear to be adding any value. The code would be clearer without it.

I could be missing something in the logic.
It is not completely clear to me where donePage is picking up is value.
I see it set in Customer Screens > editperson, ChangePassword.groovy and some of the form tags but nothing consistent.

Some things that were intentional:

1. For consistency I changed the behavior of editperson form. It returned to viewprofile on save click while all other edit forms required clicking on the done button.

2. Placed a paragraph after the buttons on the top line to separate them from the horizontal table lines. The connection to the top horizontal line made the form look like a tab form which is misleading.

3. For consistency modified the newcustomer form buttons, though it is outside of the Profile feature, since they serve the same function.

Tom
                
> eCommerce Profile Improve Button Naming Consistency
> ---------------------------------------------------
>
>                 Key: OFBIZ-4822
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: specialpurpose/ecommerce
>    Affects Versions: SVN trunk
>         Environment: demo-trunk
>            Reporter: Tom Burns
>            Assignee: Jacques Le Roux
>            Priority: Minor
>             Fix For: SVN trunk
>
>         Attachments: OFBIZ-4822 eCommerce Profile GoBack Improvement.patch
>
>
> This follows from OFBIZ-4814 bug fix.
> In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
> Example:
> Changes Password label should be "Go Back" but is "[Go Back]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Closed] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

Posted by "Jacques Le Roux (Closed) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-4822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jacques Le Roux closed OFBIZ-4822.
----------------------------------

    Resolution: Fixed

Thanks Tom,

Your patch is in trunk at revision: 1327269.

You should not have included the editcontactmech.ftl changes since you already included them in the button fix. Anyway not a big deal I easily bypassed the conflict

                
> eCommerce Profile Improve Button Naming Consistency
> ---------------------------------------------------
>
>                 Key: OFBIZ-4822
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: specialpurpose/ecommerce
>    Affects Versions: SVN trunk
>         Environment: demo-trunk
>            Reporter: Tom Burns
>            Assignee: Jacques Le Roux
>            Priority: Minor
>             Fix For: SVN trunk
>
>         Attachments: OFBIZ-4822 eCommerce Profile GoBack Improvement.patch
>
>
> This follows from OFBIZ-4814 bug fix.
> In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
> Example:
> Changes Password label should be "Go Back" but is "[Go Back]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

Posted by "Tom Burns (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/OFBIZ-4822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13257042#comment-13257042 ] 

Tom Burns commented on OFBIZ-4822:
----------------------------------

Jacques,

I did test viewprofile without authview and I did not see an impact.
I'll submit a new issue as an improvement.

Tom
                
> eCommerce Profile Improve Button Naming Consistency
> ---------------------------------------------------
>
>                 Key: OFBIZ-4822
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: specialpurpose/ecommerce
>    Affects Versions: SVN trunk
>         Environment: demo-trunk
>            Reporter: Tom Burns
>            Assignee: Jacques Le Roux
>            Priority: Minor
>             Fix For: SVN trunk
>
>         Attachments: OFBIZ-4822 eCommerce Profile GoBack Improvement.patch
>
>
> This follows from OFBIZ-4814 bug fix.
> In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
> Example:
> Changes Password label should be "Go Back" but is "[Go Back]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

Posted by "Tom Burns (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/OFBIZ-4822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13255871#comment-13255871 ] 

Tom Burns commented on OFBIZ-4822:
----------------------------------

Jacques,

Please review carefully. I found some errors in the earlier patch where the javascript submits were not correct.

Thanks,

Tom

                
> eCommerce Profile Improve Button Naming Consistency
> ---------------------------------------------------
>
>                 Key: OFBIZ-4822
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: specialpurpose/ecommerce
>    Affects Versions: SVN trunk
>         Environment: demo-trunk
>            Reporter: Tom Burns
>            Assignee: Jacques Le Roux
>            Priority: Minor
>             Fix For: SVN trunk
>
>         Attachments: OFBIZ-4822 eCommerce Profile GoBack Improvement.patch
>
>
> This follows from OFBIZ-4814 bug fix.
> In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
> Example:
> Changes Password label should be "Go Back" but is "[Go Back]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Assigned] (OFBIZ-4822) eCommerce Profile Improve Button Naming Consistency

Posted by "Jacques Le Roux (Assigned) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/OFBIZ-4822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jacques Le Roux reassigned OFBIZ-4822:
--------------------------------------

    Assignee: Jacques Le Roux
    
> eCommerce Profile Improve Button Naming Consistency
> ---------------------------------------------------
>
>                 Key: OFBIZ-4822
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-4822
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: specialpurpose/ecommerce
>    Affects Versions: SVN trunk
>         Environment: demo-trunk
>            Reporter: Tom Burns
>            Assignee: Jacques Le Roux
>            Priority: Minor
>             Fix For: SVN trunk
>
>
> This follows from OFBIZ-4814 bug fix.
> In eCommerce the naming and display of back buttons is inconsistent across the Profile Editing screens.
> Example:
> Changes Password label should be "Go Back" but is "[Go Back]"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira